LuCi - WPA2 802.1X associated stations missing


#1

I have 2 SSIDs on wlan0:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'HT20'
        option legacy_rates '1'
        option country 'GR'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'home2'
        option key 'xxxxxxxxxxx'
        option network 'vlan1'
        option encryption 'psk2'
        option wds '1'
		
config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'radius-test'
        option encryption 'wpa2'
        option auth_secret 'xxxxxxxxxxx'
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option vlan_bridge 'br-vlan'
        option vlan_naming '0'
        option auth_server '127.0.0.1'

When my client (D4:A3:DD:C9:CD:04) is connected to the first (WPA2 PSK) SSID:

iwinfo wlan0 assoclist
D4:A3:DD:C9:CD:04  -37 dBm / unknown (SNR -37)  10 ms ago
        RX: 65.0 MBit/s, MCS 7, 20MHz                     96 Pkts.
        TX: 117.0 MBit/s, MCS 14, 20MHz                   31 Pkts.
        expected throughput: 43.4 MBit/s

00:27:22:9E:DD:D2  -39 dBm / unknown (SNR -39)  160 ms ago
        RX: 58.5 MBit/s, MCS 6, 20MHz                    608 Pkts.
        TX: 58.5 MBit/s, MCS 6, 20MHz                   1659 Pkts.
        expected throughput: 20.5 MBit/s

When my client is connected to the second (WPA2 802.1X) SSID, I see only the other client:

iwinfo wlan0 assoclist
00:27:22:9E:DD:D2  -39 dBm / unknown (SNR -39)  150 ms ago
        RX: 58.5 MBit/s, MCS 6, 20MHz                    741 Pkts.
        TX: 58.5 MBit/s, MCS 6, 20MHz                   2114 Pkts.
        expected throughput: 29.7 MBit/s

Model:Netgear R6220
Architecture: MediaTek MT7621 ver:1 eco:3
Firmware Version:OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)


#2

The two different SSID should introduce two different device names, like wlan0 and wlan0-1. Try to run iwinfo to find out.


#3
Summary

This text will be hidden

I cannot test at the moment, but I am quite sure I also tested on radio1 which has only one SSID, thus, only one device name "wlan1".
Also, LuCI should show all connected clients to all radios/devices, but I see the same problem, no Associated Stations for WPA2 802.1X.
EDIT: Sorry for being inaccurate, as you suggested, iwinfo wlan0-1.1 assoclist shows correctly my 802.1X client.
Still, LuCi shows no 802.1X clients.