Luci will not install on 19.07.5 - Kernel dependency issue

Hi Team,

I have a problem with the 19.07.5 release. I tried to install Luci and got an error suggesting that a kernel dependency was to blame.
My version just installed:
Index of (root) / releases / 19.07.5 / targets / x86 / 64 /
Installed [combined-squashfs.img.gz] from (

I installed in then did
opkg update
opkg install luci

Resulting in Luci requires: Kernel 5.4.86-alphabet
Uname -a returns: Linux openwrt 6.4.85 #0

Now I am brand new to openwrt but have a lot of linux experience. It appears to me that the if I do a opkg install - it should look in a place for the appropriate installation package - especially for one of the one of the standard releases. Instead - it appears to be getting Luci from the latest spot release.

How do I resolve this issue?

Any help greatly appreciated.


If you are using an official stable release (as it appears you are), LuCI is already installed. Have you tried simply entering the IP address of the OpenWrt system into your web browser? What happens?

1 Like

Hi all,

Thanks for your quick responses. When I try the OpenWRT IP address in a browser - nothing happens.
If I do a search of the installation
find / -name "LuCI" -print yields nothing
find / -name "luci" -print yields
which to my knowledge are not installations but are temp packages of available packages and attempted installs.

In response to Peter and vgaetera,

Please note that I believe I did originally install a combined version - openwrt-x86-64-generic-ext4-combined-efi.img from teh same location a few days ago (31st Dec). At the time I installed it, I could not access LuCI until I installed it. However I was able at that time to successfully install LuCI and it did work. I screwed up the configuration and decided to reinstall that same openwrt-x86-64-generic-ext4-combined-efi.img version on 3rd Jan. As before Luci was not present, so I attempted to reinstall it. It also came up with the same error.
It is only then that I decided to try a different installation as mentioned in my first post - again on 3rd Jan.

Will try downloading the combined.ext image from the 19.07.5 repository again today.

Very confused by all this.

Hi all,

Thank you for your suggestions. I installed the combined-ext4 version suggested by vgaetera.
It does indeed contain Luci - so all is working now. Thanks for the help.


1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.