Luci Web Interface slows down massively 2-3 days after setup

this will cause the issue.

1 Like

I'm not sure if you may experience any issues as a function of IGMP snooping, STP, and BATMAN. The first two are typically functions of (external, managed) hardware switches that may or may not operate entirely as expected in this context. BATMAN is usually used as a mechanism to trunk VLANs and send them over a wireless link as a PTP type mechanism. If you're not using it, there is little need to have it all defined.

The thing is, these I have installed very very recently, to test and play with a bit. The issue I have for quite some time longer

Sure... but we want to eliminate as many variables as we can. Running as close to stock as possible will tell you if there is something unusual about either the hardware or the config (for the required changes relative to default), or if it is something you've layered on (such as those additional config options or packages).

1 Like

I'm trying to reach the wireless page, but this time the hang-ups seem much worse than usual, it won't load and often throws 'XHR request timed out'.....
I'm pretty sure that I had issues even before I changed from 2 to mixed, but let me double check that first.

OK, so I managed to flash the 22.03.2 firmware with reset. I'll leave all packages at stock, set the IPs and DHCP, etc. Wireless is to WPA2-AES
grafik

See you guys in 2-3 days again :wave:

1 Like

Out but disabled on your target device due to issue in thread, also the one you just flashed, might want to consider a master image (kernel 5.15).

1 Like

After reading about the switch bug, that is haunting the switch hardware of my WRT32x with the current release version 22, I have decided to go snapshot (for the time being). I have immediately tried to install all my needed software packages, to see whether I can run this setup the way I need it.

It‘s been almost a week since my last change/update now and luci is still running smoothly!

I still don‘t know what exactly causes the hang up, so sadly I can not post a bug report. But given that the new kernel seems to fix the issue anyway, I guess I can consider it fixed.
I can only assume that the hub-behaviour of the switch on current release version 22 caused some loop with luci. It always seemed as if it was handling a ton of requests, not being able to process my inputs, like on a ddos. But again, it‘s a far fetched guess that goes along with the theory that the patch for the hardware switch did fix this issue. Who knows.

Thanks to everyone who tried their best to guide me, your support is much appreciated!
I will upgrade to release 23 once it‘s out.

Two separate issues. You had WPA3 mixed enabled, which is an old issue from upstream mwlwifi broken FW BLOB and causes the unresponsiveness due to pegged load. The upstream kernal.org issue for broken switch is more recent and resolved upstream with 5.15 kernel.

1 Like