LuCI on nginx installation (18.06)


#1

According to luci essentials

Currently LuCI on nginx is fully supported. If any problem is found, report them to the support forum.

This leads me to here.
I tried to install

root@WRT3200:~# opkg install luci-nginx-ssl
Unknown package 'luci-nginx-ssl'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci-nginx-ssl.

and

opkg install luci-nginx
Installing luci-nginx (git-18.201.34715-c813598-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/luci/luci-nginx_git-18.201.34715-c813598-1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-nginx:
 * 	nginx-mod-luci
 * opkg_install_cmd: Cannot install package luci-nginx.

Looking in the packages list for luci I found that all packages have a date of Sun Feb 3rd, only luci-nginx has Fri Jul 20th. Not quite up to date.

root@WRT3200:~# cat /etc/os-release ; opkg find *nginx*
NAME="OpenWrt"
VERSION="18.06.2"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 18.06.2"
VERSION_ID="18.06.2"
HOME_URL="http://openwrt.org/"
BUG_URL="http://bugs.openwrt.org/"
SUPPORT_URL="http://forum.lede-project.org/"
BUILD_ID="r7676-cddd7b4c77"
LEDE_BOARD="mvebu/cortexa9"
LEDE_ARCH="arm_cortex-a9_vfpv3"
LEDE_TAINTS=""
LEDE_DEVICE_MANUFACTURER="OpenWrt"
LEDE_DEVICE_MANUFACTURER_URL="http://openwrt.org/"
LEDE_DEVICE_PRODUCT="Generic"
LEDE_DEVICE_REVISION="v0"
LEDE_RELEASE="OpenWrt 18.06.2 r7676-cddd7b4c77"
collectd-mod-nginx - 5.8.1-1
nginx - 1.12.2-1

What went wrong? What can I do?


Luci on nginx compile
#2

Hmm...I got
luci-ssl-nginx


#3

Does it depend on architecture or board? Are not all boards/architectures supported?


#4

What version of OpenWrt are you running?

If you're not on a version after the packages were added, I don't think they'll be available in the package archives for that version.


#5

eroznik in this post used the same architecture and board and even an older version. There it seems to work. Are there different package sources?

Mine are (standard for 18.06.2):

src/gz openwrt_core http://downloads.openwrt.org/releases/18.06.2/targets/mvebu/cortexa9/packages
src/gz openwrt_base http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/telephony


#6

I now changed the packet source for luci to

src/gz openwrt_luci http://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3/luci/

but i then got the error



Installing luci-ssl-nginx (git-19.038.66435-4e5111e-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3/luci//luci-ssl-nginx_git-19.038.66435-4e5111e-1_all.ipk

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-ssl-nginx:
 * 	nginx-ssl
 * 	nginx-mod-luci-ssl
 * opkg_install_cmd: Cannot install package luci-ssl-nginx.


Currently LuCI on nginx is fully supported.

I think not!


#7

You are mixing master and 18.06 stuff...


#8

I now changed the source of packages to

http://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3

but then another eror message:



Installing luci-ssl-nginx (git-19.038.66435-4e5111e-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3/luci/luci-ssl-nginx_git-19.038.66435-4e5111e-1_all.ipk

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-ssl-nginx:
 * 	libopenssl1.0.0
 * 	libuuid1
 * opkg_install_cmd: Cannot install package luci-ssl-nginx.

Can anyone tell me what is really necessary?
The stable version is not working!


#9

Use cat /proc/cpuinfo and see what's the output?

Maybe those packages are not provided on your platform?


#10
root@WRT3200:~# cat /proc/cpuinfo
processor	: 0
model name	: ARMv7 Processor rev 1 (v7l)
BogoMIPS	: 1866.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpd32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x4
CPU part	: 0xc09
CPU revision	: 1

processor	: 1
model name	: ARMv7 Processor rev 1 (v7l)
BogoMIPS	: 1866.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpd32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x4
CPU part	: 0xc09
CPU revision	: 1

Hardware	: Marvell Armada 380/385 (Device Tree)
Revision	: 0000
Serial		: 0000000000000000

why should any luci or nginx be platform dependant?


#11

Because when packages are compiled from source code, they get compiled for specific hardware (I believe this is what @CptTZ meant by "platform"). As hard as the OpenWrt community tries, not all packages get built for all hardware targets. This is the reality of most, if not all, open source software projects, not just OpenWrt.

I'm not implying that this is the case for the packages you are referring to, I'm just making a general statement about why a package might not be available for a particular "platform".


#12

And why are these packages not built automatically?
If manually, who decides what packages are beeing built or not?


#13

The packages are built automatically by the project. When packages are "missing" it is typically that something failed in the build of that package. There are status pages available from that link.

http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/ (from your output, I am assuming that is correct for your device) can also be explored to confirm that you don't have connectivity or configuration problems.

Edit: As hynman points out in the next post, you're using the wrong repo. If you're going to use snapshots, you have to do one of the following:

  • Install all the packages you want immediately
  • Reflash if your want to install other packages later
  • Try out Persistent kmods for snapshots (which I have not tried myself).

#14

You are still mixing master and 18.06...

You are trying to use a master branch packages download repo with 18.06.
The package naming and dependency checking logic has changed.


#15

as stated in my first Post using the standard package list does not work:

opkg install luci-nginx
Installing luci-nginx (git-18.201.34715-c813598-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/luci/luci-nginx_git-18.201.34715-c813598-1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-nginx:
 * 	nginx-mod-luci
 * opkg_install_cmd: Cannot install package luci-nginx.

Therefore I tried other possibilities. I really don't want to mix packages. I simply want luci with nginx and ssl Nobody could explain to me until now, why this is not working.
Sorry, I am no openwrt developer.


#16
  • Back up your configuration and any other files you want to retain
  • Get a list of your packages
  • Flash 18.06.02
  • Reinstall any packages that are not in the ROM
  • Stay on the release branch unless you're willing to either build your own images or flash a new snapshot any time you want to install packages

#17

That is, what i have done a few days ago.
I was on the release branch, but this did not work!

What can I do else? Wait until somebody has solved the problems?


#18

So back again at release branch.

Installing luci-ssl-nginx (git-18.201.34715-c813598-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/packages/arm_cortex-a9_vfpv3/luci/luci-ssl-nginx_git-18.201.34715-c813598-1_all.ipk

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-ssl-nginx:
 * 	nginx-ssl
 * 	nginx-mod-luci-ssl
 * opkg_install_cmd: Cannot install package luci-ssl-nginx.

The dependencies are missing. Why? who can correct this?


#19

Looking more closely into the history:
You are actually hitting a special case where nginx support in LuCI was erroneously enabled for a few days in summer 2018 (just after the 18.06 branching) and then it was removed with the commit https://git.openwrt.org/?p=project/luci.git;a=commit;h=14c73faf313a85f9a70b21b1afd84a47e28a93c0

There are apparently some compiled luci-nginx leftovers in some 18.06 download directories, but installing them fails as the major part of the general nginx package support is not yet there.

(possibly an admin like @jow could delete the compiled old luci-nginx binaries from the 18.06 download repo, but in any case the binaries do not work)

Discussion on the topic in https://github.com/openwrt/luci/issues/1948

In any case you are without luck, as the nginx support in LuCI is not active in 18.06. You need a master snapshot for that.


Double pages for LuCI installation
#20

Thank you for this information. Then also somebody should remove the information in the doc luci essentials at the top of my post, because this information is wrong:

Currently LuCI on nginx is fully supported. If any problem is found, report them to the support forum.

It is not supported on 18.06