Luci offline installation for MR6400

Hello i installed the openwrt to my modem MR6400 it is a tplink. The firmware is working. But they idea i could not do "opkg update" i am receiving failed to establish connection. Check your network settings and connectivity. This 4g modem can work as 4G modem or as Normal router using port 4 as wan interface.

i found the minimal installation here: https://wiki.openwrt.org/doc/howto/luci.essentials#minimalistic.offline.installation

But i have windows i can't do it.

I tried "vi /etc/config/network" in ssh of the modem, and received the bellow:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5c:0e34:3611::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config interface 'wan6'
config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 0t'

How i can install it offline from windows or what i can change to make the router connect to the network through port4/wan. So i wont use the 4g i will connect it to my second router.

1 Like

One way...

OpenWrt/LEDE documentation...

https://openwrt.org/docs/guide-user/network/wan/start

2 Likes

Hi there
Hello i installed the openwrt to my D'link dwr 116 . The firmware is working. But they idea i could not do “opkg update” i am receiving failed to establish connection. Check your network settings and connectivity. This 4g modem can work as 4G modem or as Normal router using port 4 as wan interface.

i found the minimal installation here: https://wiki.openwrt.org/doc/howto/luci.essentials#minimalistic.offline.installation 12

But i have windows i can’t do it.
the router cannot connect to internet.
is there any one who can guide me(with simple and clear steps) how to configure WAN PORT using command line prompt to enable internet on the router. Please help!