Luci index.html not showing properly

I installed a webserver on my Banana Pi R64 ages ago and decided to just put the server on spare laptop instead. However, when I rename the original file back to index.html neither that, http://192.168.1.1/cgi-bin/luci/ nor just going to 192.168.1.1 in the browser worked. Instead it just downloads the file to the downloads folder of my pc. I have even tried creating the index anew using the code I found at the github address but still the same result.

Thanks,

Aaron

did you restore the original web server and config too ?

1 Like

oops! No, I can't remember the configuration?

uninstall the uhttpd package, and reinstall it, config files should be restored.

No packages removed.
Collected errors:
 * print_dependents_warning: Package uhttpd is depended upon by packages:
 * print_dependents_warning: 	uhttpd-mod-ubus
 * print_dependents_warning: These might cease to work if package uhttpd is removed.

 * print_dependents_warning: Force removal of this package with --force-depends.
 * print_dependents_warning: Force removal of this package and its dependents
 * print_dependents_warning: with --force-removal-of-dependent-packages.

it tells you your options, pick one.

Not sure how to use?

--force-removal-of-dependent-packages

opkg --force-removal-of-dependent-packages uhttpd

Just tried to navigate to http://192.168.2.1/cgi-bin/luci/ in the address bar but still does not display the login but downloads the page instead.

which one is it ?

and have you uninstalled or stopped the old web server ?
there can be only one application serving port 80.

The 2.1 address! I can't remember which on I installed.

Edit:

Found out by checking which ports were in use that I was using the lighttpd webserver. Had to follow the instructions on the following page to get luci working again.

https://openwrt.org/docs/guide-user/services/webserver/lighttpd

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.