Luci hangs and SQUASHFS error: hardware gone bad?

Hardware: Linksys EA7500v2
Version: OpenWrt 21.02.1, r16325-88151b8303

My router running OpenWRT works fine until some days ago. Now, when I access LUCI via firefox by (my configured IP address), it hangs with only the words "LuCI - Lua Configuration Interface" and won't proceed further. I can still SSH into this router. Internet and LAN connections still works perfectly.
I have two other routers of different models configured as dumb AP (, and LuCI works perfectly on them.

Troubleshooting steps tried:

  • /etc/init.d/uhttpd restart
    Does not solve the issue
  • Rebooting
    Does not solve the issue
  • netstat -nlp | grep uhttpd
tcp        6      0    *               LISTEN      1964/uhttpd
tcp        0      0   *               LISTEN      1964/uhttpd
tcp        0      0 :::80                   :::*                    LISTEN      1964/uhttpd
tcp        0      0 :::443                  :::*                    LISTEN      1964/uhttpd
  • logread or logread -f
    It spits out a lot or error messages like the below.
Sun May 15 18:27:31 2022 kern.err kernel: [  672.538751] SQUASHFS error: Unable to read page, block 38354a, size d528
Sun May 15 18:27:31 2022 kern.err kernel: [  672.545627] SQUASHFS error: Unable to read fragment cache entry [38354a]
  • df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.8M      3.8M         0 100% /rom
tmpfs                   123.1M    300.0K    122.8M   0% /tmp
/dev/ubi0_1              24.3M      2.7M     20.3M  12% /overlay
overlayfs:/overlay       24.3M      2.7M     20.3M  12% /
tmpfs                   512.0K         0    512.0K   0% /dev

The SQUASHFS seems like the NAND flash is corrupted (and maybe affected LuCI) to me, but I am not sure if this is really the case. Any help in further troubleshooting is appreciated. In particular, I would like to know if it is time to write off the router and purchase new hardware. Thank you.

Have you tried to reinstall OpenWrt?

I echo @eduperez there: a simple reinstall might be all it takes.

It may simply be that a single page or a couple have gone bad on the NAND and if that's the case, there's no need to throw the baby out with the bathwater. Ubi has been designed to be able to work around bad areas.

1 Like

Fair enough. I may need to do the reinstall at a time when everybody in the family isn't using the Internet though.

Seems that I need to look into ways to quickly reinstall and provision the router when some pages of the NAND go bad. Maybe backup+restore plus a list of manually installed packages are enough.

If this is something that happens repeatedly, I would change the device immediately.

1 Like