Luci doesn't work with HTTPS after sysupgrade to 19.07.7 custom image

Update. In fact it's working... but only over HTTP! HTTPS is the one failing.

Well I upgraded my Archer C7 v5 from 18.06 to 19.07.7. The good news is that it worked and it's running 19.07.7 and I have SSH access. The bad news is that luci doesn't work anymore.

When I reload the page, I get the standard msg Firefox can’t establish a connection to the server at 192.168.49.3.

Configs worked out-of-the-box, All leds are working, WiFi works, my phone uses LAN to traceroute google.com. opkg reports luci is installed:

# opkg list-installed
ath10k-firmware-qca988x-ct - 2020-07-02-1
base-files - 204.2-r11306-c4a6851c72
bash - 5.0-4
busybox - 1.30.1-6
ca-bundle - 20200601-1
cgi-io - 19
curl - 7.66.0-3
dropbear - 2019.78-2
firewall - 2019-11-22-8174814a-3
fstools - 2020-05-12-84269037-1
fwtool - 2
getrandom - 2019-06-16-4df34a4d-3
hostapd-common - 2019-08-08-ca8c2bd2-7
htop - 3.0.5-1
ip-full - 5.0.0-2.1
ip6tables - 1.8.3-1
iptables - 1.8.3-1
iputils-ping - 20101006-1
iw-full - 5.0.1-1
jshn - 2020-05-25-66195aee-1
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 4.14.221-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d
kmod-ath - 4.14.221+4.19.161-1-1
kmod-ath10k-ct - 4.14.221+2019-09-09-5e8cd86f-1
kmod-ath9k - 4.14.221+4.19.161-1-1
kmod-ath9k-common - 4.14.221+4.19.161-1-1
kmod-cfg80211 - 4.14.221+4.19.161-1-1
kmod-gpio-button-hotplug - 4.14.221-3
kmod-hwmon-core - 4.14.221-1
kmod-ip6tables - 4.14.221-1
kmod-ipt-conntrack - 4.14.221-1
kmod-ipt-core - 4.14.221-1
kmod-ipt-nat - 4.14.221-1
kmod-ipt-offload - 4.14.221-1
kmod-mac80211 - 4.14.221+4.19.161-1-1
kmod-nf-conntrack - 4.14.221-1
kmod-nf-conntrack6 - 4.14.221-1
kmod-nf-flow - 4.14.221-1
kmod-nf-ipt - 4.14.221-1
kmod-nf-ipt6 - 4.14.221-1
kmod-nf-nat - 4.14.221-1
kmod-nf-reject - 4.14.221-1
kmod-nf-reject6 - 4.14.221-1
kmod-nls-base - 4.14.221-1
kmod-phy-ath79-usb - 4.14.221-1
kmod-usb-core - 4.14.221-1
kmod-usb-ehci - 4.14.221-1
kmod-usb-ledtrig-usbport - 4.14.221-1
kmod-usb2 - 4.14.221-1
libblobmsg-json - 2020-05-25-66195aee-1
libc - 1.1.24-2
libcap - 2.27-1
libcurl4 - 7.66.0-3
libelf1 - 0.177-1
libgcc1 - 7.5.0-2
libip4tc2 - 1.8.3-1
libip6tc2 - 1.8.3-1
libiwinfo-lua - 2019-10-16-07315b6f-1
libiwinfo20181126 - 2019-10-16-07315b6f-1
libjson-c2 - 0.12.1-3.1
libjson-script - 2020-05-25-66195aee-1
liblua5.1.5 - 5.1.5-3
liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
libmbedtls12 - 2.16.10-1
libmnl0 - 1.0.4-2
libncurses6 - 6.1-5
libnl-tiny - 0.1-5
libpopt0 - 1.16-2
libpthread - 1.1.24-2
libreadline8 - 8.0-1
libubox20191228 - 2020-05-25-66195aee-1
libubus-lua - 2019-12-27-041c9d1c-1
libubus20191227 - 2019-12-27-041c9d1c-1
libuci20130104 - 2019-09-01-415f9e48-4
libuclient20160123 - 2020-06-17-51e16ebf-1
libxtables12 - 1.8.3-1
logd - 2019-06-16-4df34a4d-3
lua - 5.1.5-3
luci - git-21.107.58152-c19c716-1
luci-app-firewall - git-21.107.58152-c19c716-1
luci-app-opkg - git-21.107.58152-c19c716-1
luci-base - git-21.107.58152-c19c716-1
luci-lib-ip - git-21.107.58152-c19c716-1
luci-lib-jsonc - git-21.107.58152-c19c716-1
luci-lib-nixio - git-21.107.58152-c19c716-1
luci-mod-admin-full - git-21.107.58152-c19c716-1
luci-mod-network - git-21.107.58152-c19c716-1
luci-mod-status - git-21.107.58152-c19c716-1
luci-mod-system - git-21.107.58152-c19c716-1
luci-proto-ipv6 - git-21.107.58152-c19c716-1
luci-proto-ppp - git-21.107.58152-c19c716-1
luci-theme-bootstrap - git-21.107.58152-c19c716-1
mtd - 24
ncdu - 1.14-1
netifd - 2021-01-09-753c351b-1
odhcp6c - 2021-01-09-64e1b4e7-16
odhcpd-ipv6only - 2020-05-03-49e4949c-3
openwrt-keyring - 2019-07-25-8080ef34-1
opkg - 2021-01-31-c5dccea9-1
procd - 2020-03-07-09b9bd82-1
rpcd - 2020-05-26-67c8a3fd-1
rpcd-mod-file - 2020-05-26-67c8a3fd-1
rpcd-mod-iwinfo - 2020-05-26-67c8a3fd-1
rpcd-mod-luci - 20201107
rpcd-mod-rrdns - 20170710
rsync - 3.1.3-2
swconfig - 12
terminfo - 6.1-5
uboot-envtools - 2018.03-3.1
ubox - 2019-06-16-4df34a4d-3
ubus - 2019-12-27-041c9d1c-1
ubusd - 2019-12-27-041c9d1c-1
uci - 2019-09-01-415f9e48-4
uclient-fetch - 2020-06-17-51e16ebf-1
uhttpd - 2020-10-01-3abcc891-1
urandom-seed - 1.0-1
urngd - 2020-01-21-c7f7b6b6-1
usign - 2020-05-23-f1f65026-1
vim-fuller - 8.1-6
wireless-regdb - 2020.11.20-1
wpad-basic - 2019-08-08-ca8c2bd2-7
zlib - 1.2.11-3

# df -hT
Filesystem           Type            Size      Used Available Use% Mounted on
/dev/root            squashfs        6.0M      6.0M         0 100% /rom
tmpfs                tmpfs          60.8M     64.0K     60.7M   0% /tmp
/dev/mtdblock9       jffs2           7.4M    368.0K      7.1M   5% /overlay
overlayfs:/overlay   overlay         7.4M    368.0K      7.1M   5% /
tmpfs                tmpfs         512.0K         0    512.0K   0% /dev

I used this command to build image:
make image PROFILE=tplink_archer-c7-v5 FILES=~/openwrt/imgbuilder/archerC7/files/ PACKAGES="bash rsync vim-fuller ip-full iputils-ping curl htop ncdu luci luci-base luci-app-opkg luci-mod-admin-full luci-mod-network luci-mod-status luci-mod-system luci-theme-bootstrap -dnsmasq -firewall -luci-app-firewall -kmod-ipt-nat -kmod-ppp -kmod-pppoe -kmod-pppox -ppp -ppp-mod-pppoe -luci-proto-ppp"

Found the solution: How enable https for openwrt gui - #4 by hnyman

1 Like

A little tip for the packages in your build config.
You have added luci and luci-base and some other luci packages. And then removed some luci packages.

But doesn’t the package luci install as dependables most of the other luci packages you have added manually. And luci-base is a slim luci which you have installed full version of with the luci package.

So you give the imagebuilder a lot to do which isn’t necessary.

1 Like

Like flygarn12 says, the above list of luci packages makes no sense.
Some of those are meta-packages, which only include other packages.

E.g.

  • luci-mod-admin-full = luci-base + luci-mod-network + luci-mod-status + luci-mod-system

As you want SSL, I think that you actually want just an SSL enabled LuCI without firewall and ppp protocol modules.
That would be just this: luci-ssl -luci-app-firewall -luci-proto-ppp

1 Like

So should I remove luci-base from the list?

The luci packages I removed should be the GUI for packages I removed like firewall. At first I even believed they made luci be removed too but I checked opkg list and luci was there.

tnx! I'm gonna use that then.

This is the current command
make image PROFILE=tplink_archer-c7-v5 FILES=~/openwrt/imgbuilder/archerC7/files/ PACKAGES="bash rsync vim-fuller ip-full iputils-ping curl htop ncdu luci-ssl -dnsmasq -firewall -luci-app-firewall -kmod-ipt-nat -kmod-ppp -kmod-pppoe -kmod-pppox -ppp -ppp-mod-pppoe -luci-proto-ppp"

I just added luci-ssl and removed luci-app-firewall together with firewall and luci-proto-ppp together with ppp packages.

Luci or luci-base is the two sides of the same coin.

You need to make up your goal if you want a slim install or a normal install.
Luci is everything and luci-base is what you need to start luci.

When you install luci you get this:
https://openwrt.org/packages/pkgdata/luci
You can compare this to luci-base in the packages database.

But luci is standard install in a stable build package. If you look in the manifest file (you find this next to the imagebuilder file from the download page) you se what 19.07.7 is installing as standard.
So you will get full luci anyway if you haven’t removed it or your device profile has it deleted because your device lack memory space.

And if you run the command

make info

You get in the list what packages your specific device will add to the firmware file.

But a big note!
Luci is a dependable for luci-ssl so you can’t runt a slim install and also have HTTPS because luci must be installed.
https://openwrt.org/packages/pkgdata/luci-ssl

1 Like

Not quite so.

Luci is an empty meta-package that pulls in the needed packages, including luci-base via luci-mod-admin-full (which is another empty meta-package).

Wrong. That is just the LuCI core files, but no web server, etc. No actual functionality.

EDIT:
the dependendy tree more visibly...

1 Like

That's very nice to leave as future reference for ppl with similar difficulties.

I just need to build an image with all packages I need, limited to the 8MB flash storage. I only removed packages related to routing and their luci GUIs, because my AP is on bridge.

It's consuming around 6MB so I have some free storage to fit 21.02.

On a side note. If I could, I'd remove from luci all pages for editing configs and leave only pages/blocks that show info. Because I keep all configs under Subversion repo and wanna set everything directly on their txt.

Hint: the dependency tree is shown when you try to install a package in the LuCI software page. (you can only do that for uninstalled packages, so I used luci-ssl as example instead of luci-ssl-openssl that I actually use. Thatswhy the wolfssl stuff in shown as uninstalled in the tree)

1 Like