Luci does not work in Firefox after upgrade

Yesterday I've upgraded OpenWrt to 19.07.2 (using openwrt-19.07.2-ath79-generic-tplink_archer-c59-v1-squashfs-sysupgrade.bin )
I have a few issues after that (e.g. pppoe can not connect to provider, Luci over https does not work), and one of them is I can not work with Luci with Firefox, while in Chrome it works.
I use Chrome 81.0.4044.129 64 bit and Firefox 76.0b8 64 bit.
When I try to login to router in Firefox, I see start page (authentification page) again and again. I've checked that Firefox does not send cookie it received from Luci, while Chrome does. But it worked well before upgrade, so it looks like some error in Luci. May be it does not comply now to some very strict cookie rules of Firefox, while previous Luci version does.

LuCI both in 19.07.x and master works ok with

Name Firefox
Version 76.0
Build ID 20200429185419
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Are you using http or https? I am not sure I have used http any time before today. So may be the problem is at http only.
And I forget to write I'm at Win7 X64.

https (with openssl as the crypto lib in OpenWrt)

Are you using any plugin in Firefox?
You might try firefox without any add-on plugins.

2 Likes

I've just set https and it works in Firefox too. So the possible Luci error is at http only

Works quite normally with http, both with master and with 19.07 branch.
I disabled https from my routers and tested with plain http.
Works ok.

19.07:

Master:

Clear all site cookies from firefox and try again

Thanks for testing. Stil does not work for me. But it is not a real problem - works fine via https. Tested with another Firefox version - works via http good. So may be it is Firefox beta bug. Or some another hard reproduceable bug - does not matter.
BTW, I've found why internet connection did not work after upgrade - eth0 and eth1 interfaces are exchanged in 19.07. I've changed configs and now it works, too.

Not likely, as I am using Firefox beta channel myself and it works for me.
(currently release 76.0, apparently, until the next version 77 beta cycle starts in the next few days)

Delete the existing "sysauth" cookie manually, then it should work. This happens when LuCI gets downgraded from HTTPS to HTTP and the old session cookie is still set, usually after a sysupgrade or reset to defaults. Firefox prevents overwriting the HTTPS sysauth cookie with an HTTP one. Probably some security heuristic.

3 Likes

You can also try to start FF in "safe mode"

Screen Shot 2020-05-08 at 13.51.02

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.