Luci dependency on Kernel 5.15.10

Hi all,

I have a NXP LS1046ardb dev kit running openwrt. Using this image https://mirror-03.infra.openwrt.org/releases/23.05.3/targets/layerscape/armv8_64b/

I want to try to install a gui to manage it but I am not able to install Luci.
I get this error:

pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-nat found, but incompatible with the architectures configured
satisfy_dependencies_for: Cannot satisfy the following dependencies for luci: kernel (= 5.15.150-1-d33551d795c4b2995eeb350a35af26f4

Ive found this post which says to install a stable or latest version. I assume I am running the latest since I am running OpenWRT 25.05.3 which is from May 2024. How can I fix this?

Thanks

Let's see what is happening here:

ubus call system board
cat /etc/opkg/distfeeds.conf

Install release from firmware selector?

{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 2",
        "model": "LS1046A RDB Board",
        "board_name": "fsl,ls1046a-rdb-sdboot",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "layerscape/armv8_64b",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@OpenWrt:/# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core https://downloads.openwrt.org/releases/23.05.3/targets/layerscape/armv8_64b/packages
src/gz openwrt_base https://downloads.openwrt.org/releases/23.05.3/packages/aarch64_generic/base
src/gz openwrt_luci https://downloads.openwrt.org/releases/23.05.3/packages/aarch64_generic/luci
src/gz openwrt_packages https://downloads.openwrt.org/releases/23.05.3/packages/aarch64_generic/packages
src/gz openwrt_routing https://downloads.openwrt.org/releases/23.05.3/packages/aarch64_generic/routing
src/gz openwrt_telephony https://downloads.openwrt.org/releases/23.05.3/packages/aarch64_generic/telephony
root@OpenWrt:/#

Strange to see that error. I agree with @brada4 that the easiest way would be to reinstall. Grab a fresh image from the firmware selector.

Ive re installed it from the firmware selector and this one already comes pre installed with Luci.. Strange. But it seems to be working! Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.