In trying to fix other problems (see here ) I've messed up my installation of OpenWRT. I've restored it to the point where my laptop can get the internet connecting wirelessly to my router (Linksys E8540). However, I can't get Luci (my router) to see the internet to download software packages/updates.
When I go to System -> Software -> Update lists… It tries for a few seconds and then returns with the error:
Collected errors:
* opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/targets/mediatek/mt7622/packages/Packages.gz, wget returned 4.
* opkg_download: Check your network settings and connectivity.
…
I've set the DNS server to match what my IP gives, but that didn't fix the problem.
Help!
Seems likely that your DNS is the problem. Did you disable AGH?
Let's see the latest config files:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
Here you go. Thanks again!
root@Luci:~# ubus call system board
{
"kernel": "5.15.134",
"hostname": "Luci",
"system": "ARMv8 Processor rev 4",
"model": "Linksys E8450 (UBI)",
"board_name": "linksys,e8450-ubi",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.0",
"revision": "r23497-6637af95aa",
"target": "mediatek/mt7622",
"description": "OpenWrt 23.05.0 r23497-6637af95aa"
}
}
root@Luci:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdae:bd07:4e2b::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
root@Luci:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '0'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
option port '54'
list server '75.75.75.75'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
list dhcp_option '6,192.168.1.1'
list dhcp_option '3,192.168.1.1'
list dns '2601:8c1:c100:e86::1'
list dns 'fdae:bd07:4e2b::1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config host
option name 'jmini6'
option dns '1'
option mac '...5C'
option ip '192.168.1.123'
config host
option name 'j15Pro'
option dns '1'
option mac '...BD'
option ip '192.168.1.249'
config host
option name 'EmmaPhone'
option dns '1'
option mac '...BD'
option ip '192.168.1.148'
config host
option name 'LilyPhone'
option dns '1'
option mac '...AF'
option ip '192.168.1.248'
config host
option name 'EmmaSchoolComputer'
option dns '1'
option mac '...7E'
option ip '192.168.1.240'
config host
option name 'LilySchoolComputer'
option dns '1'
option mac '...FB'
option ip '192.168.1.136'
config host
option name 'Luci'
option dns '1'
option mac '...AA'
option ip '192.168.1.1'
config host
option name 'TrishaiPad'
option dns '1'
option mac '...58'
option ip '192.168.1.218'
config host
option name 'j12'
option dns '1'
option mac '...A9'
option ip '192.168.1.135'
config host
option name 'RainMachine'
option dns '1'
option mac '...70'
option ip '192.168.1.198'
config host
option name 'Thranduil'
option dns '1'
option mac '...A5'
option ip '192.168.1.150'
config host
option name 'NintendoSwitch'
option dns '1'
option mac '...C3'
option ip '192.168.1.239'
config host
option name 'Doorbell'
option dns '1'
option mac '...9D'
option ip '192.168.1.122'
root@Luci:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
Remove these two lines.
It doesn’t look like you implemented any of my suggestions from the previous thread.
psherman:
Remove these two lines.
This worked. Thanks.
I have not implemented the suggestions from the previous thread because I got stuck here. Now that this is resolved, I'll go back and work on the others.
system
Closed
January 18, 2024, 4:29am
6
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.