Luci broken after update

I have this script i run every once in a while and today it seems to have broke luci. Currently luci is stuck on the page (shown in screenshot) and clicking the button "to login" nor rebooting has helped.

root@Skittles:/mnt/usb1/shareroot/software/openwrt/scripts# ./opkg-upgrade.sh

Simple OPKG Updater v0.4.1

Done | Updating package lists
Done | Getting upgradable packages list

Packages available for upgrade: 5

+-----+-------------------+--------------------------+--------------------------+
|   # | Package           | Current                  | Update                   |
+-----+-------------------+--------------------------+--------------------------+
|   1 | libmbedtls12      | 2.28.4-1                 | 2.28.5-1                 |
|   2 | luci-app-firewall | git-23.208.40260-9504081 | git-23.285.27691-e23911e |
|   3 | luci-base         | git-23.236.53405-fc638c8 | git-23.292.78378-27fb6e5 |
|   4 | luci-mod-status   | git-23.236.53405-9b3c7d3 | git-23.292.78378-9adda4a |
|   5 | netifd            | 2023-09-19-7a58b995-1    | 2023-10-20-5590a80e-1    |
+-----+-------------------+--------------------------+--------------------------+

Proceed with upgrade? (Y/y to proceed) y

.... | Upgrading packages

Upgrading libmbedtls12 on root from 2.28.4-1 to 2.28.5-1...
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/base/libmbedtls12_2.28.5-1_arm_cortex-a9_vfpv3-d16.ipk
Removing obsolete file /usr/lib/libmbedx509.so.2.28.4.
Removing obsolete file /usr/lib/libmbedtls.so.2.28.4.
Removing obsolete file /usr/lib/libmbedcrypto.so.2.28.4.
Upgrading luci-app-firewall on root from git-23.208.40260-9504081 to git-23.285.27691-e23911e...
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/luci/luci-app-firewall_git-23.285.27691-e23911e_all.ipk
Upgrading luci-base on root from git-23.236.53405-fc638c8 to git-23.292.78378-27fb6e5...
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/luci/luci-base_git-23.292.78378-27fb6e5_arm_cortex-a9_vfpv3-d16.ipk
Upgrading luci-mod-status on root from git-23.236.53405-9b3c7d3 to git-23.292.78378-9adda4a...
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/luci/luci-mod-status_git-23.292.78378-9adda4a_arm_cortex-a9_vfpv3-d16.ipk
Upgrading netifd on root from 2023-09-19-7a58b995-1 to 2023-10-20-5590a80e-1...
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/base/netifd_2023-10-20-5590a80e-1_arm_cortex-a9_vfpv3-d16.ipk
Failed to send request: Operation not permitted
Configuring libmbedtls12.
Configuring luci-base.
Configuring luci-mod-status.
Configuring luci-app-firewall.
Collected errors:
 * resolve_conffiles: Existing conffile /etc/config/luci is different from the conffile in the new package. The new conffile will be placed at /etc/config/luci-opkg.
 * resolve_conffiles: Existing conffile /etc/config/ucitrack is different from the conffile in the new package. The new conffile will be placed at /etc/config/ucitrack-opkg.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/arm_cortex-a9_vfpv3-d16/base/netifd_2023-10-20-5590a80e-1_arm_cortex-a9_vfpv3-d16.ipk, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_install_pkg: Failed to download netifd. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package netifd.
Done |
Upgrade finished

Please check for config file conflicts!

Uncaught (in promise) SessionError: Login session is expired
  at notifySessionExpiry (luci.js?v=git-23.292.78378-27fb6e5:194:474)
  at async Promise.all (/cgi-bin/luci/index 0)
    at Object.raise (luci.js?v=git-23.292.78378-27fb6e5:155:3)
    at notifySessionExpiry (luci.js?v=git-23.292.78378-27fb6e5:194:474)
    at async Promise.all (/cgi-bin/luci/index 0)
1 Like

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

Or, in other words, don't run scripts that just blindly upgrade packages. You're not using a full blown distro and can't rely on the updater catching problems.

is there some opkg commands i can run to rolls these back? since its just a few
and likely just the luci one

Hi

Hard reset of device (factory) is best what you could do
it will start with factory installed packages

3 Likes

ok, thank you

i did, and it fixed it of course

i wont run that script again

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.