Luci-app-wireguard - no refresh

I observed that the Wireguard status page doesn't auto refresh with updated stats/traffic. A reload of the page is required.

kmod-wireguard - 5.10.161-1
luci-app-wireguard - git-21.322.66896-8ae208d
luci-proto-wireguard - git-22.327.45657-14403fe
wireguard-tools - 1.0.20210424-3
luci - git-20.074.84698-ead5e81
luci-ssl - git-20.244.36115-e10f954
1 Like

Works flawless for me, I assume 'Refreshing' is showing in the upper right corner, not 'Paused'?

kmod-wireguard - 5.10.161-1
luci-app-wireguard - git-23.018.72712-6d712c3
luci-proto-wireguard - git-22.327.45657-14403fe
wireguard-tools - 1.0.20210424-3
luci - git-20.074.84698-ead5e81
luci-ssl - git-20.244.36115-e10f954

Your luci-app-wireguard is an older revision, how did you update to latest release?

Different versions.

Thanks for the update.

I'm now running git-23.018.72712-6d712c3 - still no refresh. The refresh icon is present at the upper-right, but the page is not actually refreshing.

Have you tried different browsers? Clearing cache or running in a private windows. And if you update do you to keep the settings?

This is occurring on mamy devices. Some new. Yes private, incognito, regular, multiple browsers.

I stare, pass traffic in my tunnel, wait 5 minutes, no refresh. Other pages refresh as normal.

Mmmh, would be interesting to let run wg show in a loop every few seconds to see if there's something wrong with Wireguard reporting the data.

wg show is OK. That's how I verify traffic is increasing and there's a latest handshake.

Well, that makes it even more mysterious.

I assume there are no Javascript blocker or ubock origin installed. Although I don't know how the refresh is implemented for the wireguard page.

Nope - that's the main reason I verified with private/incognito tabs.

All the other pages with autorefresh work. I was actually shocked when you said refreshing is working for you, so I just waited til I updated to 22.03.5, assuming it was the old versions. Autorefresh has never worked for me on the WG Status page.

To be clear, you're referencing the Wireguard Status page, correct? -

Since 22.03.5 exhibits the same behavior, I decided to make an updated posting.

I was on holiday when I wrote it and using an Apu2 as a travel router and all traffic went over a WG tunnel.

Tonight or tomorrow I'll set ip up again at home to verify but there is only one wireguard status page I thought :thinking:. I'll let you know.

1 Like

I've just checked on my router and the wireguard page is refreshing every 5 seconds. I'm using a snapshot build that was built on 2 May.

1 Like

So, I happened to have one available, it was running 22.03.3. After installing git-23.018.72712-6d712c3 - still no autorefresh.

So I upgraded it to today's SNAPSHOT: OpenWrt SNAPSHOT, r22784-1645c34d56

And I noticed something different instantly, so I re-verified that I wasn't crazy:

root@OpenWrt:~# opkg install luci-app-wireguard 
Package luci-proto-wireguard (git-23.073.81399-59a6f06) installed in root is up to date.

Notice I tried to install APP and it responded with PROTO. :wink:

  • The screen looks completely different
  • And autorefresh is working

So it appears that this was fixed at some time and will likely appear in version 23.xx.0.

Thanks for looking into it for me!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.