Luci-app-ntpc package removed? Why?

Hi all
I wanted to build an assembly, but the luci-app-ntpc package is missing
version 23.05.2

The fact is that I disabled the sysntpd service, I don’t want the time to be updated every minute, so I installed the luci-app-ntpc package, configured the scheduler to reboot the router once a day and the time is updated once after the router is rebooted, very convenient.
I wanted to build a new build, but the package disappeared)

See https://github.com/openwrt/luci/pull/6970

You may try to migrate to sysntpd

and the function in sysntpd - Use servers advertised via DHCP does not work, in any case, it has never worked for me on three different Internet providers.
That’s why I found a normal alternative to luci-app-ntpc, it’s better to update the time once a day than every minute with port 123 always open, which is vulnerable

and then how to configure sysntpd?
to set the time update interval yourself )

I tried it at first, but it’s not very convenient and practical, configure sysntpd in the scheduler, start, stop, disable.
Make at least the normal settings in sysntpd, since you decided to remove luci-app-ntpc, by the way the package was good and it worked fine

Hi @fkl7834456

try this way:

config timeserver 'ntp'
        option enabled '1'
        option use_dhcp '1'
        option enable_server '0'
        list server 'fdff:255::30'
        list server 'fd00:1:255::1'

with option enable_server '0' there is no port 123 open
you could test by your self
netstat -anp|grep 123
and will see that nothing is listening on 123

option use_dhcp '1' does not work

you could check actual NTP servers with
as you could see, there is two source in use

ps -w | grep ntp

 2642 root      1340 S<   /usr/sbin/ntpd -n -N -S /usr/sbin/ntpd-hotplug -p fdff:255::30 -p fd00:1:255::1

```

i tried to reply for your statement that port 123 is always open

real NTP servers work, but I don't want them to keep port 123 open, it's always open

https://github.com/openwrt/packages/pull/23569 the sources were unmaintained (and dead) for years (which may even pose a security risk) and there exists alternatives to fulfill the same requirements, which is what preceded the removal from LuCI.

did you tried ?

option enable_server '0'

there is no port 123 open
you could test by your self

netstat -anp|grep 123

what other security? the time was updated after the reboot and that's it.

turn it back on, let people decide for themselves whether it’s safe or not )

I used to struggle with sysntpd for months and the result was zero, it’s absolutely no good, this utility needs to be improved, this utility is the vulnerability

at least fix the use_dhcp '1' option, it doesn't work, check it yourself

it is not true

config timeserver 'ntp'
        option use_dhcp '1'
        option enable_server '0'
        option interface 'vlan99'
ps | grep ntp
/usr/sbin/ntpd -n -N -S /usr/sbin/ntpd-hotplug -p 192.168.99.1

as you could see, ntp client is grabbed ntp server from vlan99 interface
maybe you missing
option interface

config timeserver 'ntp'
option use_dhcp '1'
option enable_server '0'
option interface 'vlan99'
I'll check this option

in your case, it will be
option interface 'wan' or whatever

does not work, the wan interface is installed