LuCI APP: luci-app-3ginfo - 3ginfo gui (Info about 3G/LTE connection)

Yes, that's it.
I'm not going to explain it all in this thread now.

It should show more, the question is why it can't see the modem. Do you have any additional packages to support the modem? Do you have more modems?

I have only this modem. I think all of packages are installed that i need because the connection is online. I have some special gcom files, and a service to get public ip. Is that problem?

This can be a problem if many scripts want to communicate with the modem.

It's very sad. I need that modifications, because without that i don't get connected and don't get public ip address.

Try using another comm port for 3ginfo.
Alternatively use your own custom script only to establish the initial connection and not hold the port afterwards.

I need the script for reconnections. How? comm port that i use now is ttyACM1? Or what?

I installed the latest version of 3ginfo-lite and there are more infos now. But there is no SIM info, TAC, primary band, CA band S1-S4. I tried it without my connect script, with simple ncm protocoll (ncm.json) and the situation is the same. How can I solve this?

If it helps, here is the original RouterOS AT command log for this modem

If i run commands with sms_tool, it works:

root@OpenWRT_x86-64:~# sms_tool -d  /dev/ttyACM0 at "AT+CGMI"

+CGMI: "MikroTik"

root@OpenWRT_x86-64:~# sms_tool -d  /dev/ttyACM0 at "AT+CGMR"

R11e-LTE6_V034

root@OpenWRT_x86-64:~# sms_tool -d  /dev/ttyACM0 at "AT+CPIN?"
+CPIN: READY

root@OpenWRT_x86-64:~# sms_tool -d  /dev/ttyACM0 at "AT+CGSN"
*********************

root@OpenWRT_x86-64:~#

How do I told 3ginfo-lite to use it?

Hi @yodee13
You don't have many things because I need to add them for this modem. If commands for missing values are known, it will not be a problem to complete them.

These missing command are available in the log i attached? I think the modem type, fw type, sim imei is in there

Modem type:

sms_tool -d  /dev/ttyACM0 at "AT+CGMM"

FW type:

sms_tool -d  /dev/ttyACM0 at "AT+CGMR"

IMEI:

sms_tool -d  /dev/ttyACM0 at "AT+CGSN"

I think the primary and CA band are available because these data is readable on "Technology". But the technology is LTE not? And the Primary and CA and is B1 + B20.

You see what is missing, give me the commands with the result of the commands. For IMEI data, you can replace digits/letters.

I see that the aggregation is on, the scripts will be corrected/updated. There is much to add and improve.

So You think that:

The ISMI command works too:

sms_tool -d  /dev/ttyACM0 at "AT+CIMI"

If i run the command, that i found in /usr/share/3ginfo-lite/modem/2cd20004

sms_tool -d /dev/ttyACM0 at "at+cesq;+zcainfo?;+zpas?;+zc
ellinfo?"

The result is:

root@OpenWRT_x86-64:~# sms_tool -d /dev/ttyACM0 at "at+cesq;+zcainfo?;+zpas?;+zc
ellinfo?"

+CESQ: 31,99,255,255,24,34
,
+ZCAINFO: 133,1,3203,476,10,34,25,14,30;289,1,20,6200,10,23,22,7,19

+ZPAS: "LTE_A","CS_PS"

+ZCELLINFO: 787753,133,LTE B1,476

root@OpenWRT_x86-64:~# ,

There are a LTE_A, that is the technology, not? And the B1 is the primary band i think.

Hi @yodee13
I did a package update, see if it shows more.

Much better :slight_smile: Now only the primary and ca detalils are missing.

Still a lot of data to improve but ok, there is tiny progress.

Send me in private message the result of this command:
sh -x /usr/share/3ginfo-lite/3ginfo.sh

I don't want to make a bigger mess in this topic.

i sent :wink: