LuCI APP: luci-app-3ginfo - 3ginfo gui (Info about 3G/LTE connection)

I could probably add Cellmapper to the search from the button at the bottom of the page. I just need to know the correct search string on the page.

I would prefer not to add more parameters, I wanted the package to be very readable and as simple as possible.

It looks like I will have to add this myself )
Question: which tool do you use to minify your js files?
I've tried a few online services and all of them are complaining even on unmodified 3gdetail.js from your Git.

I had such a nice package.. :expressionless:

What do you want to add?
I wrote above to add possibly a new search for "Cellmapper" from the button.

Already added:
enb

I don't really need the integrated search facility.

A Raspberry PI 4B.

root@OpenWrt:/# opkg update

Downloading https://github.com/4IceG/Modem-extras/blob/main/myrepo/Packages.gz

Updated list of available packages in /var/opkg-lists/IceG_repo

Downloading https://github.com/4IceG/Modem-extras/blob/main/myrepo/Packages.sig

Failed to decode signature

Signature check failed.

Remove wrong Signature file.

Unfortunately, there is no sms-tool package for this platform and someone has to compile the package manually.

@IceG, I downloaded an .ipk from OpenWRT and installed sms_tool (version 2022-03-21-f07699ab-1) for Raspi. Looks like this:

root@OpenWrt:~# sms_tool -d /dev/ttyUSB1 -b 57600 status
Storage type: SM, used: 0, total: 20

Is that the required package?

I suspect that signature check failure is not related to sms_tool.

Oh cool, the sms-tool was available. Yes, this is a required package.

Okay, first step done. What about the failing signature check? Seems to be related to 4IceG repo. What might cause this and how can I resolve it?

@hans.b Have you followed all the steps in the link below? (Steps to add my repository).
https://github.com/4IceG/Modem-extras

I thought I did. Tried once again, this time successful. Luci-app-3ginfo displays more info than expected with Fibocom FM-150.

1 Like

I see "Waiting for connection data..." in "Connection statistics" like in the screenshot above. What could be the reason for that?

Edit: fixed by changing interface from wwan0 to @wan

1 Like

Works for me, too. Thanks!

Hello!

Can I make it work this on X86-64 with Mikoritk R11e LTE6? Somehow? Now I only see this:

Hi @yodee13
Uninstall what you have installed and check this package
https://github.com/4IceG/luci-app-3ginfo-lite

I have removed luci-app-3ginfo and 3ginfo-text. Then I installed wget-nossl, and downloaded sms-tool and installed. Then what? I don' t understand :frowning:

Edit: Okay! I have downloaded the lite package and installed. Now i see this

And now it would be appropriate to add what is missing knowing the at commands for this modem.

And where are the config files of 3ginfo?

The question is why you need configuration files.
Now you need to check how the modem presents itself in the system (VID and PID identifier on the USB bus).

Script that read data (for this modem)
usr/share/3ginfo-lite/3ginfo-addon/2cd20004

This is what I need?

Number 001/003  ID 2cd2:0004  R11e-LTE6

And what lines I need to edit, to get missing values? I have connection log about this modem. Is this useful?