Luci-app-https-dns-proxy problem

a router with openwrt firmware is connected to another router with standard tp-link firmware
and when you change the dynamic ip address on the first router that the provider issues
https-dns-proxy stops working until you restart this service,
as I understand it, it is not bound to to the gateway of the first router, and to the gateway issued by the provider,
and when this gateway is changed, the https-dns-proxy service continues to use the old gateway.
How to bind luci-app-https-dns-proxy to the gateway of the first router ?
need to manually set the gateway in luci-app-https-dns-proxy settings
I made a temporary solution for myself to restart the service every 10 minutes by adding this to the task scheduler
*/10 * * * * /etc/init.d/https-dns-proxy restart
but this is not very convenient

You have three threads concerning http-dns-proxy .

Seems like valid answers have been posted to one;

  • this, the original may benefit from trying to hack you ISP dynamic IP renewal time. Looks to me from the above quote your have a workaround. Perhaps reading this will help.

Concerning you ZRam thread.. it appears you don't need it as Out of Memory conditions would be self evident and you are just adding a package that is not necessary.

"You should be able to force a renewal by running: kill -USR1 $(pidof udhcpc) "
The IP address of the wan on the first router can change at any time and updating manually is not an option. I thought at least here on the forum they would help me with normal advice, but apparently it’s not fate :slight_smile:

The problem went into the fog with the new firmware version 22.03.3
Thank you!!! Everything works great!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.