Luci-app-https-dns-proxy has something changed?

I updated my build and the menu says HTTP/2 is not supported on this system
installed curl and the message disappeared
tell me this is how it should be ?
Previously, this message did not exist and there was no need to install Curl, the libcurl4, libnghttp2 packages were installed automatically and everything was fine, something has changed in these packages themselves and now it is necessary to install curl for HTTP/2, as i understand it ?