Luci-app-https-dns-proxy broken after latest update?

Hello all. I recently reinstalled OpentWRT 22.03.5 on my DIR-2640 A1 which meant I had to reinstall the associated software. After doing so I noticed that there is a new version of "luci-app-https-dns-proxy" dated 2023-10-25-1. This version does not seem to auto-run on router reboot. I have to log into Luci and manually click the "Restart" button in the https-dns-proxy Luci interface page for the DoH to start working.

I have uninstalled it and reinstalled it again to confirm if any issues happened during install but no errors come up. I just notice that when I run dnsleaktest.com it reports that the DoH is not working (I set 8.8.8.8 as my vanilla DNS and run Cloudflare as the DoH so when I run tests, it's obvious if DoH is working or not). Is anyone having issues with the latest version of luci-app-https-dns-proxy (2023-10-25-1)?

Could be a simple race condition...

If you upgraded the package - https://openwrt.org/meta/infobox/upgrade_packages_warning

I did see that article but that should not apply to my current issue. I re-flashed the device (down from 23.05 to 22.03.5) so all packages I have installed are fresh downloads with no upgrades.

Its seems fine for me (Linksys WRT3200). DNS queries redirect correctly to quad9 and cloudflare

Are you using the version labeled 2023-10-25-1 ? Have you tested with dnsleaktest.com and does it show any plaintext dns servers too?

If you want to learn how to connect to your router over ssh and immediately after reboot capture and post the output of logread -ehttps, please post it here, I'll have a look.

This issue has been resolved. I just removed the plaintext DNS addresses from the WAN interface and replaced them with 127.0.0.1 with the http-dns-proxy settings configured with functional DNS addresses. Works fine and dnsleaktest.com shows only the encrypted servers now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.