Luai2c fails to build

Hello all

I have no idea where to post this.

While building a fresh image build system on Lede 17.01 i get the following error.

make[3]: Entering directory '/home/wrt/openwrt/feeds/packages/lang/luai2c'
mkdir -p /home/wrt/openwrt/dl
SHELL= flock /home/wrt/openwrt/tmp/.luai2c-1.0.0.tar.xz.flock -c '  	 echo "Checking out files from the git repository..."; mkdir -p /home/wrt/openwrt/tmp/dl && cd /home/wrt/openwrt/tmp/dl && rm -rf luai2c-1.0.0 && [ \! -d luai2c-1.0.0 ] && git clone luai2c-1.0.0 && (cd luai2c-1.0.0 && git checkout 1.0.0 && git submodule update --init --recursive) && echo "Packing checkout..." && export TAR_TIMESTAMP=`cd luai2c-1.0.0 && git log -1 --format='\''@%ct'\''` && rm -rf luai2c-1.0.0/.git && 	tar --numeric-owner --owner=0 --group=0 --sort=name ${TAR_TIMESTAMP:+--mtime="$TAR_TIMESTAMP"} -c luai2c-1.0.0 | 	xz -zc -7e > /home/wrt/openwrt/tmp/dl/luai2c-1.0.0.tar.xz && mv /home/wrt/openwrt/tmp/dl/luai2c-1.0.0.tar.xz /home/wrt/openwrt/dl/ && rm -rf luai2c-1.0.0;     '
Checking out files from the git repository...
Cloning into 'luai2c-1.0.0'...
remote: Repository not found.
fatal: Authentication failed for ''
Makefile:45: recipe for target '/home/wrt/openwrt/dl/luai2c-1.0.0.tar.xz' failed
make[3]: *** [/home/wrt/openwrt/dl/luai2c-1.0.0.tar.xz] Error 128
make[3]: Leaving directory '/home/wrt/openwrt/feeds/packages/lang/luai2c'
package/Makefile:105: recipe for target 'package/feeds/packages/luai2c/compile' failed
make[2]: *** [package/feeds/packages/luai2c/compile] Error 2
make[2]: Leaving directory '/home/wrt/openwrt'
package/Makefile:101: recipe for target '/home/wrt/openwrt/staging_dir/target-mips_mips32_musl-1.1.16/stamp/.package_compile' failed
make[1]: *** [/home/wrt/openwrt/staging_dir/target-mips_mips32_musl-1.1.16/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/wrt/openwrt'
/home/wrt/openwrt/include/ recipe for target 'world' failed
make: *** [world] Error 2

I have no idea how to fix this or where to start yet, but before I have resolved the other 30 odd error I will join the club of fixes and report.


Looks like the repo is down, its URL has changed, or the certificate is bad/unrecognized since the Makefile was last updated.

Edit: curl -v gives in its diagnostic output

< HTTP/1.1 301 Moved Permanently
< Date: Mon, 10 Sep 2018 15:57:11 GMT
< Content-Type: text/html
< Content-Length: 178
< Server:
< Location:

Have you checked that the CA bundle/files on your build machine are current?

Hey Jeff

The repo has moved, I have been trying to resolve this myself for a day or so but have not been very successful.

I tried to download the file manually that I found but the build system still stops at the same point.

I do have 31 other errors I need to get through, but from what I have seen, if I can solve this one, others will also solve themselves.


No "mrpace2" repo on Github that I see!

commit 7c2c1cd66a23d8bc12e7afe8766e790c4c94e79e
Author: Yousong Zhou <>
Date:   Fri Jun 29 10:05:36 2018 +0800

    luai2c: remove it for missing sources
    The github repo is gone
    Signed-off-by: Yousong Zhou <>

I have but the file comes as a .tar.gz, i tried to extract and repackage as a tar.xz and copied the file to the /dl directory and I get the error I pasted.

I have no idea how to update the code, no wait, I am not confident enough yet to try and change the code myself yet.

So I posted the issue here, knowing that there are more interlingual people here who would come across it and be able to rectify the issue

the package is available to download from
but the build still fails as the package is a tar.gz

If you want to build with the archived tarball, then you could change the package Makefile to point to its location on the old server (or on, or to a local "file" URL.

Excuse my ignorance here, but which planet do you want me to re-align with your telegraphic satellite.

I have no urgency,
I have a functional build, but I thought it would be polite to report it somewhere useful for people to be aware

SO i will wait for it to work and then I may find some time to interface some of my goodies into the BCRM63xx platforms I get for dirt dirt cheap.
My last purchase was for 6 units for $3 and they seem to be a crap load cheaper than Arduino's

So I will keep on building my Lede and reporting what I find and hopefully if this is the wrong place someone will point me in the right place to report such issues.

No problem, I thought you needed the package to meet your needs.

Package bugs can be reported by looking at the package table for the "right" place[Name_pkg-dependencies*~]=luai2c


and/or to the maintainer directly

PKG_MAINTAINER:=Frank Edelhaeuser <>
1 Like

Thank you , your a :star: