LTE modem with QMI protocol

I have a linksys E4200 v1 router with an LTE usb dongle zte mf821 (branded polsat). I have LEDE Reboot SNAPSHOT r23-312b9dc ( but I also tried all versions of openwrt and LEDE).
I'm connected on WAN network through the LTE dongle using QMI protocol (qmi_wwan), all working fine but I have an issue that happens on both wireless and wired network: sometimes browsing over internet the connection on browser freeze.
Into my log I found some of this error:
kern.warn kernel: [ 89.084296] REJECT(src wan)IN=wwan0 OUT= MAC=02:1d:1a:7b:cb:8a:02:50:f3:00:00:00:08:00 SRC= DST= LEN=40 TOS=0x00 PREC=0x00 TTL=61 ID=4096 DF PROTO=TCP SPT=80 DPT=49987 WINDOW=0 RES=0x00 RST URGP=0

kern.notice kernel: [ 744.416085] nf_ct_tcp: invalid packet ignored in state ESTABLISHED IN= OUT= SRC= DST= LEN=52 TOS=0x00 PREC=0x00 TTL=49 ID=0 DF PROTO=TCP SPT=80 DPT=50106 SEQ=3507324767 ACK=3615518895 WINDOW=29200 RES=0x00 ACK SYN URGP=0 OPT (020405640101040201030309)

kern.warn kernel: [ 832.757869] REJECT(src wan)IN=wwan0 OUT= MAC=02:1d:1a:7b:cb:8a:02:50:f3:00:00:00:08:00 SRC= DST= LEN=40 TOS=0x00 PREC=0x00 TTL=240 ID=47652 DF PROTO=TCP SPT=443 DPT=50062 WINDOW=9300 RES=0x00 ACK RST URGP=0

On most of them I see that my router receive request from http/https port of external server that try to connect to my router IP, why? I can solve this issue changing my firewall configuration?

I found this article related 3 qmi_wwan bugs that could be the cause of my issue, and if I understand well they has been solved into 3.8 linux kernel:

Could you confirm me if these issue could be the cause of my problem?
if no, could you help me to understand what could be the cause of my issue?
I can also confirm you that I have this issue only when I'm connected on Internet with my USB dongle, if I use the WAN port I have no issue.

I changed the category, probably this issue could be related to development..

nobody can help me?

I can tell you I have the same issues on the linksys wrt1900acs, 3200, and pi3. On kernel 4.9

I've tried using uqmi on my qmi modem on all of them and it will work wired for a little bit then wireless for a little while then after about 5 min everything is gone. I switched the modem to mbim and tried umbim and same issue.

I dont know what is going on. I can use mbim in 4.4 kernel pretty well and stable but there is no raw_ip qmi support so I can't test my modem in 4.4 in qmi.

I've heard that people have these problems more with static internet facing public ips which I have with sprint. It seems that non routable ips don't have the issue.

Here is something strange though. I installed openvpn and am running PIA vpn and the problems disappear on all kernels and routers.

I've been researching and it seems it has something to do with the loopback and the server and sta. I'm not sure what the fix is but it seems fixable as the vpn does solve it.

I could try to test mbim instead of qmi on my router, but I didn't understand howto switch between the 2 protocols, could you explain me it?
Moreover, on my router I installed OpenVPN and I configured a client VPN to connect on my Network office (where I have an OpenVPN Server), the connection go UP, but after some minutes the connection freeze and it is automatically restarted (and it is impossible to work in this way). I also tried to use client VPN installed on my PC, that works very well on all internet connection where I tried it (the OpenVPN connection never go down), but when I'm onnected on my router with LTE modem the connection freeze continuously.

You will need to put the modem itself into mbim mode if possible.

Hello Westem,
I tried to load mbim driver.

root@E4200:~# lsmod
bcma_hcd 2848 0
brcmutil 4224 0
cdc_mbim 4000 0
cdc_ncm 11712 1 cdc_mbim
cdc_wdm 7712 2 cdc_mbim,qmi_wwan

but I continue to have the same issue..

Hello all,
nobody else can suggest me what other type of Analisys can I do? My issue could be related to ZTE LTE dongle? or it coud be related to my linksys router? or it is a netfilter issue? or it is QMI protocol issue?
collecting tcpdump messages could be useful for analisys?
there is someone who use my own configuration and doesn't have any issues?

Hello all,
I bought another router (netgear DGN3500) and I installed lede firmware on it and connected the same LTE usb dongle zte mf821, and now all workin fine. I continue to see the "invalid paced ignored" message into log but there are no more REJECT messages into system log.

Then, is the problem related only on linksys E4200 router?