LTE modem via QMI / WAN (Connects, without Internet)

I'm using a zbt-we826 device that flashed over to the latest compatible version (OpenWrt 19.07.2 r10947-65030d81f3 / LuCI). I'm using Quectel modems (EC25-AF) with Twilio SIM cards.

The article OpenWrt has up @ did get everything in place and connected with QMI (I've got a connected data status, IP addresses posted, and all). Per the article the firewall was assigned to WAN too. Everything in place but for whatever reason there's still no internet ability.

Info below:

Potentially something was missed in the OpenWrt guide and can be fixed from figuring out the problem here!? If it helps: I am unable to ping the gateway.

I never used the EC25 with QMI. But Serial instead (3g-wwan), on many installs. Works like a charme.
Give it a try, at least, to verify SIM etc.

(QMI setup it a bit tricky, very often. You will find lot of problem reports here on the forum.)

I may try out serial on my backup hardware, the QMI process was pretty straight forward not too complicated. The AT commands are showing full connections, but just nothing being transmitted lol

I had similar effect when trying to use Sierra MC7455 with QMI on 19.07.2. Finally, I got it to work after flashing latest Sierra firmware into the modem. Verify firmware on the EC25.

From the output of your uqmi command it looks like you are not connected to an LTE network, its wcdma which is 3g, but you do have all of the routing information in terms of ip address etc.
The rssi is not great, especially if the intention is an LTE connect, hence why the modem has connected to 3g rather than lte.
The single most important thing for LTE is the signal strength/quality, -94 RSSI is not a great signal, if possible move the modem around the premises to try and get a better signal, aiming to get the RSSI closer to 50-60, (-50 is very good, -60 is pretty good, the connection is still fast, I lose LTE connectivity below -85).
Upgrading the modem firmware is a good idea, as is using the super simple ppp-serial connection suggested by @reinerotto to work out if an LTE connect is possible given the signal that can be received.
You'll never get a ping return from the gateway IP address as its CG-NAT and probably drops pings (my provider SFR in France drops any pings)
I think if you get a better signal it will all be good.

Got it thank you, my LTE rssi is -71, when I force LTE I'm unable to get an IP address (whereas wcdma was able to).

Is there a way to have QMI display the full details of it's configuration i.e. what APN/PDP it's attempting with?

Further more I've actually tried another active SIM from T-Mobile directly this time, the registration did validate but it's not able to capture an IP address via LTE.

I sort of gave up on getting a reliable connection using openwrt's qmi, as it was my only way of connecting it was really important to make it as reliable as possible as easily as possible, So I used the Dairyman's ROOTer firmware and it really helped working out how it all works.
I don't know how to query the qmi connection, modemmanager is better for debugging whats going on, the ROOTer fw is incredible for debugging your connection,
Maybe install modemmanager, it pulls in the full libqmi library so gives you loads more ways to see how the connection is happening

Thanks for that insight, I did install modemmanager while testing and I knew the results were promising but I quickly got rid of it and moved back to QMI as I had found more resources on that. I will move back to modemmanager and give it a shot!

ROOTer worked out of the box, just saved me a ton more time here... Thank you. Hoping this thread gets scraped by google so anyone on the same topic and makes the quick same move here! Literally 5 minutes to get it up and running with firm flash time too!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.