LTE modem looses connection

I used luci-proto-qmi to set up a LTE connection. It connects OK using this in /etc/config/network:

config interface 'WWAN'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option auth 'none'
        option ipv6 '1'
        option pincode '1234'
        option apn 'Provider_APN'
        option pdptype 'ipv4v6'

It then works for 1.5 to 2 days until it looses its DHCPv4 lease for WWAN_4 and even though Luci still displays addresses for IPv6 and IPv6-PD on the WWAN parent interface, there is no connectivity. If I manually restart the interface it works again. [Edit: This time around resetting the interface via Luci didn't work, rebooting the router did]
The only thing I find in the logs is udhcp failing to renew it's lease, nothing else regarding WWAN, qmi or cdc-wdm...uqmi --get-current-settings says "Out of call", but --get-signal-info displays a LTE signal...
I'm at a loss here, can somebody point me in the right direction?

Thanks in advance!

please see Wwan disconnect every 6 hours

Thanks, but that seems to be slightly different in that my interface does not go down, at least it's not logged. The only thing I see is udhcp: renewing nicely every hour, trying to renew but failing, trying to discover but failing, giving up. I also know that German providers like to disconnect consumers, but usually they are very punctual about it, like every 24h. Which also doesn't match what I'm seeing.

Anyways: if there are re-connection issues with openWrt, how would one go about to "take care about re-connect"? I see that uqmi has an --autoconnect option for --start-network and there's also a --set-autoconnect enabled parameter but this doesn't result in any changes to the config (that I found)??

I would use this OpenWrt based firmware and configure connection monitoring with reconnect there.

Sorry @AndrewZ, but that was really a waste of my time. This ROOter-thing won't even connect. And what's worse, it somehow managed to lock my SIM card which I can't seem to PUK-unlock on the device itself. I assume that the OS, in an overzealous attempt to do everything automatically, tried to connect without a PIN one-too-many times, using the automatically detected modem, the existing WWAN interface and an empty default profile? That's kinda annoying, given I have to open up my router to change the SIM...

And even if it had worked, I highly doubt I would have stuck with it. With OpenWrt I was slightly annoyed that it came with dnsmasq enabled by default (I already have a couple of DNS / DHCP servers). Can you image how I felt about ROOter? 10 network interfaces? 11 services? Load-balancing? 1/3 less free flash? Just not my style...

Sorry to hear that, improvement may be needed here.