LTE Modem Doesn't Work

Okay, so, it works now
I found out that I just need to restart the router lol

so here's the complete step by step solution with LuCI

  • Install this packages kmod-usb-net-cdc-ether usb-modeswitch
  • Reboot your router
  • Then run dmesg | grep cdc
    it should now output the interface like this
root@OpenWrt:~# dmesg | grep cdc
[   15.408332] cdc_ether 1-1:1.0 eth1: register 'cdc_ether' at usb-101c0000.ehci-1, CDC Ethernet Device, 00:a0:c6:00:00:00
  • Go to LuCI then on Network > Interfaces > Devices enable whatever interface that dmesg display
  • Then go to Interfaces tab, click Add new interface...
  • Put whatever name you want, select DHCP client, and select the interface that dmesg display
  • Click create
  • Don't forget to configure the firewall
  • And that is it, it should work

and if it still doesn't work, then do this additional steps

  • Install this additional package picocom usbutils kmod-usb-serial-option
  • Run lsusb
    it should output your modem id
root@OpenWrt:~# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux 5.10.176 ohci_hcd Generic Platform OHCI controller
Bus 001 Device 002: ID 2cb7:0001 Fibocom,Incorporated Fibocom Mobile Boardband
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.176 ehci_hcd EHCI Host Controller
  • Then run this, replace 2cb7 0001 with your modem ID, echo "2cb7 0001" > /sys/bus/usb-serial/drivers/option1/new_id
  • Then run ls /dev | grep ttyUSB
    it should output like this
root@OpenWrt:~# ls /dev | grep ttyUSB
  • Find the correct serial by running picocom /dev/ttyUSB{num} to each serial port, then run the command ATI
  • After you found it, then set up the APN by running this command AT+CGDCONT=1,"IP","{your apn}","", change the {your apn} with your operator APN
  • Then run this AT+GTRNDIS=1,1
  • And it should work

or just follow this guide


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.