LTE interface works only until first reboot

I read this tutorial and I created the LTE interfate for the Sierra Wireless EM7455. Internet connection is perfect but when I reboot the router I lost the "Virtual dynamic interface" and I can't connet to internet. Anybody has the same issue?

I had similar issue. I ran /etc/init.d/network restart after the reboot.

Didn't work, the Virtual dynamic interface is still lost.

I take a look on /etc/config/network and there is nothing about Virtual dynamic interface, probably this is why I lost it on first reboot.

What protocol do you use to your LTE interface, QMI?

1 Like

Yes, I use QMI protocol.

Try ModemManager

No need for nodemmanager.

What is "Virtual dynamic Interface" ? You mean something like wwan ?
I used MC7455 in the past, worked like a charm.

You need something like

config interface 'wwan'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option apn 'vzwinternet'
option auto '0' #Will start in rc.local

to edit into /etc/config/network

In rc.local I inserted at top:

#Next one just in case ...
comgt -d /dev/ttyUSB2 -s /etc/setup/reset_modem.gcom
ifup wwan
#Thats all. dnsmasq listens on all interfaces, anyway.


 set com 115200n81
 set comecho off
 set senddelay 0.02
 waitquiet 0.2 0.2
 flash 0.1

 send "AT!RESET^m"
 get 1 "^m" $s
 get 1 "^m" $s
 let x = len($s)
 if x<2 goto continue
 let $s = $right($s, x-1)
 print $s
 exit 0

Virtual dynamic Interface is created automatically when you add the interface "QMI Cellular". The strange thing is that I can see it in Luci but not in /etc/config/network. Could is this the reason why I lost it at the next reboot? Anyhow without this interface I have no internet connection.

I think the virtual dynamic interface is created when the LTE modem connects to the cellular network and gets an IPaddress.
Can you see if our LTE modem is connected and has recieved an IPaddress?

Sorry to say, I only used the MC7455/QMI combo in custom built images, having no LuCi.
This required manual edit of /etc/config/network, as stated. Result is a new interface, "wwan", which you also see in "ifconfig".
With your LuCi based setup I can not help.

Let's start from the begining. After installing all modules I created a new interface, this:

onfig interface 'wwan'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option apn 'MYAPN'

After was automatically created a new interface called "Virtual dynamic Interface". I have internet connection but after first reboot Virtual interface disappear and I can't connect internet.

So I tried a second method after full reset. Command:

uqmi -d /dev/cdc-wdm0 --start-network --apn MYAPN --autoconnect

New interface:

config interface 'wwan'
option ifname 'wwan0'
option proto 'dhcp'

Command uqmi -d /dev/cdc-wdm0 --get-data-status sais "connected" but I have no rx from wwan.

What's wrong?

I completed my initial post. Pls, check upwards.

Thanks, but what is this script?

Just what the title says, to reset the modem. There are very spurious occasions, the modem/connection hangs. Which will be handled via soft reboot+reset of modem. For industrial apps you also need to take care of the (almost) impossible.

Great, this is the solution!!

I had only to add "option delay '30'" in network config.

Thanx for pointing out. Because it explains, why also my setup works: The manual start of wan-connection in rc.local also works like a delay.

I have only a problem that still persists... every 4-5 hours I lost internet connection. Don't seems a modem issue because it is in connected status and if I reboot the lan interfce it come back online.

Keep the link busy. I.e. having a permanent ping. Some routers/switches cut idle connections.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.