LTE connection disconnects

I'm using ZyXEL LTE5398-M904 and lately my LTE connection started disconnecting and won't automatically reconnect unless I restart the interface.

It's hard to say why it started happening, but my last changes were to update modem firmware to Revision: EG18EAPAR01A13M4G and also updating OpenWRT to latest build.

here is my configuration:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxx:xxx:fd1e::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'

config interface 'wan_eth'
	option proto 'dhcp'
	option device 'lan1'
	option metric '10'

config interface 'wan_lte'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'telenor.fwa'
	option pincode 'xxxx'
	option auth 'none'
	option pdptype 'ipv4'
	option metric '20'

config interface 'lan'
	option proto 'static'
	option device 'br-lan'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config device
	option name 'wwan0'
root@OpenWrt:~# picocom /dev/ttyUSB3
picocom v3.1

port is        : /dev/ttyUSB3
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
hangup is      : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,
logfile is     : none
initstring     : none
exit_after is  : not set
exit is        : no

Type [C-a] [C-h] to see available commands
Terminal ready
AT+CEREG?
+CEREG: 0,2

OK
AT+CGDCONT?
+CGDCONT: 1,"IP","telenor.fwa","0.0.0.0",0,0,0,0

OK
AT+CGPADDR
ERROR
AT+QENG="servingcell"
+QENG: "servingcell","LIMSRV","LTE","FDD",242,01,331D303,223,1450,3,5,5,81AE,-93,-9,-64,14,-,-,34

OK
AT+GMR
EG18EAPAR01A13M4G

OK
AT+QCFG="band"
+QCFG: "band",0x8d0,0x1a0080800d5,0x0

OK
AT+QMBNCFG="List"
+QMBNCFG: "List",0,0,0,"ROW_ReduceComb",0x0801FC02,202010291
+QMBNCFG: "List",1,0,0,"ROW_Generic_3GPP_PTCRB_GCF",0x0801FE02,201910231
+QMBNCFG: "List",2,0,0,"Norway_Telia_Commercial",0x08012420,201906131
+QMBNCFG: "List",3,0,0,"Optus_Australia_Commercial",0x08014400,201812291
+QMBNCFG: "List",4,0,0,"Telstra_Australia_Commercial",0x08010F00,202201101
+QMBNCFG: "List",5,0,0,"TIM_Italy_Commercial",0x08012B00,201902181
+QMBNCFG: "List",6,0,0,"France-Commercial-Orange",0x08010B21,201906281
+QMBNCFG: "List",7,0,0,"UK-VoLTE-Vodafone",0x08010426,201908011
+QMBNCFG: "List",8,0,0,"Spain-Non_VoLTE-Telefonica",0x08010C20,201910291
+QMBNCFG: "List",9,0,0,"Telenor_Norway_Commercial",0x08014300,201902181
+QMBNCFG: "List",10,0,0,"Telia_Sweden",0x08012400,201902251
+QMBNCFG: "List",11,0,0,"ROW_Commercial",0x0801080A,201904121

OK

the interesting part (which you haven't posted), is the log after a disconnect ...

In my experience, LTE connections are not reliable by nature. I would use an upper layer (Modem manager, watchcat, ...) to handle disconnections.

the problem is that disconnects happen very randomly, after 1-5 days, and I don't always notice it until after a few days, and OpenWRT only shows me logs for the current day

there's an USB port, start writing your log(s) there, to a flash drive.