Low speed over ethernet but correct over wifi

Hello, I have openwrt installed on my router with a 600 Mbps fiber optic line. My problem is that when I do a speed test under the 5Ghz Wi-Fi network I get a very high speed (530-550 Mbps), on the other hand, under ethernet I only get one speed of, maximum 230-250 Mbps. I have tried with several computers connected by ethernet but I do not find the problem. It's pretty weird. Attached the network and wireless configuration.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch
	option name 'switch0'

config interface 'lan'
	option ifname 'eth2 eth3 eth4'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option multicast_querier '0'
	option igmp_snooping '0'
	option macaddr '9c:9d:7e:75:28:4b'
	option ipaddr '192.168.31.1'
	option ieee1905managed '1'

config interface 'eth1'
	option ifname 'eth1.20'
	option keepup '1'

config interface 'ifb'
	option ifname 'ifb0'

config interface 'wan'
	option proto 'dhcp'
	list dns '192.168.31.101'
	list dns '192.168.31.101'
	option mtu '1488'
	option peerdns '0'
	option ifname 'eth1.20'
	option macaddr '44:AD:B1:D4:76:33'

config interface 'miot'
	option ifname 'wl13'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.32.1'
	option netmask '255.255.255.0'


WIRELESS

config wifi-device 'wifi0'
	option type 'qcawificfg80211'
	option channel 'auto'
	option macaddr '9c:9d:7e:75:28:4c'
	option hwmode '11axa'
	option htmode 'HT80'
	option disabled '0'
	option txbf '3'
	option ax '1'
	option txpwr 'max'

config wifi-iface
	option device 'wifi0'
	option ifname 'wl0'
	option network 'lan'
	option mode 'ap'
	option wpsdevicename 'XiaoMiRouter'
	option channel_block_list '36,40,44,48,52,56,60,64'
	option ssid 'Xiaomi_34EF_5G'
	option encryption 'mixed-psk'
	option key '7AAF29C8'
	option disabled '0'
	option wscconfigstatus '0'

config wifi-device 'wifi1'
	option type 'qcawificfg80211'
	option macaddr '9c:9d:7e:75:28:4b'
	option hwmode '11axg'
	option htmode 'HT40'
	option disabled '0'
	option txbf '3'
	option ax '1'
	option txpwr 'max'
	option channel '13'

config wifi-iface
	option device 'wifi1'
	option ifname 'wl1'
	option network 'lan'
	option mode 'ap'
	option wpsdevicename 'XiaoMiRouter'
	option ssid 'Xiaomi_34EF'
	option encryption 'mixed-psk'
	option key '7AAF29C8'
	option disabled '0'
	option wscconfigstatus '0'

config wifi-device 'wifi2'
	option type 'qcawificfg80211'
	option channel 'auto'
	option macaddr '9c:9d:7e:75:28:4d'
	option hwmode '11ac'
	option htmode 'HT20'
	option disabled '0'
	option txbf '3'
	option ax '1'
	option bw '20'

config wifi-iface
	option device 'wifi2'
	option ifname 'wl2'
	option mode 'sta'
	option ssid 'MIIOT_DEV'
	option encryption 'none'
	option wpsdevicename 'XiaoMiRouter'
	option disabled '0'

config wifi-iface 'miot_2G'
	option ifname 'wl13'
	option network 'miot'
	option encryption 'none'
	option device 'wifi1'
	option mode 'ap'
	option hidden '1'
	option maxsta '20'
	option ssid '25c829b1922d3123_miwifi'
	option bsd '0'
	option ap_isolate '1'
	option disabled '0'
	option bindstatus '0'
	option userswitch '0'

Can you check that any of these computers gets a faster throughput in a different lan ?
I do have the same effect with one computer, and it is a problem of this computer, not even related to the ethernet usb-c adapter. Also the throughput numbers are very familiar to me.