Low speed on LAN on Dumb AP Linksys E8450

Tried solutions in similar posts like this and still not working.

My main and AP is a Linksys E8450. So what happens is the LAN and wifi speeds on the dumb ap is throttled to 95 up/down speed. On the main router it is 400down/414up on both wifi/lan normal operation.
But after I restart the Dumb ap, briefly for sometime I get the main router speeds of 400down/414up but after sometime it goes back to 95 up/down. NO hardware/software offloading enabled on both Linksys E8450.

MY SETTINGS

From DUMB AP

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb2:a3a5:a353::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan.99'
	option proto 'dhcp'
	option delegate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option delegate '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'lan1:u*'
	list ports 'wan:t'

config interface 'guest'
	option proto 'dhcp'
	option device 'br-lan.4'
	option delegate '0'

Wireless DUMB AP

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option band '2g'
	option htmode 'HT40'
	option channel 'auto'
	option country 'PA'
	option cell_density '0'
	option txpower '28'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'M4'
	option encryption 'psk2'
	option key '9884750176_'
	option ieee80211r '1'
	option mobility_domain '789D'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'HE160'
	option channel 'auto'
	option cell_density '0'
	option he_su_beamformee '1'
	option he_bss_color '8'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Madan'
	option encryption 'psk2'
	option key '4^Mz23uJv_Mm'
	option ieee80211r '1'
	option mobility_domain '123F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Madan+'
	option encryption 'psk2'
	option key '9884148280_'
	option network 'guest'
	option ieee80211r '1'
	option mobility_domain '321F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Madan+'
	option encryption 'psk2'
	option key '9884148280_'
	option network 'guest'
	option ieee80211r '1'
	option mobility_domain '321F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

FROM MAIN ROUTER

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd47:a1a1:d04d::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.86.1'
	option device 'br-lan.99'
	option delegate '0'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option password 'QSSC14ft'
	option ipv6 'auto'
	option delegate '0'
	option username '103643018287'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.87.1'
	option netmask '255.255.255.0'
	option device 'br-lan.4'
	option delegate '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:t'

MAIN ROUTER WIRELESS

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option band '2g'
	option htmode 'HT40'
	option channel 'auto'
	option cell_density '0'
	option txpower '28'
	option country 'PA'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'M4'
	option key '9884750176_'
	option ieee80211r '1'
	option mobility_domain '789D'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'HE160'
	option cell_density '0'
	option channel 'auto'
	option he_su_beamformee '1'
	option he_bss_color '8'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Madan'
	option key '4^Mz23uJv_Mm'
	option encryption 'psk2'
	option ieee80211r '1'
	option mobility_domain '123F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Madan+'
	option encryption 'psk2'
	option key '9884148280_'
	option network 'guest'
	option ieee80211r '1'
	option mobility_domain '321F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Madan+'
	option encryption 'psk2'
	option key '9884148280_'
	option network 'guest'
	option ieee80211r '1'
	option mobility_domain '321F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

This sounds like a cable issue. 95Mbps is indicative of a 100M link, rather than 1Gbps which would not be a bottleneck here.

Check your cable that connects between your routers, as well as the ports themselves for any debris or damage. If you can use a new/known good short cable to test, that should hopefully show that the speeds are indeed being capped by the other cable you are using.

I am using a cat 7 amazonbasics cable for all my setup and both my E8450's are new ( like 2 month old). The version of openwrt is the latest stable on both main and AP. I have checked ports and cable and they are not the issue.

Just because you are using a high rated cable doesn’t guarantee that it is good. Have you tried a replacement cable?

I am posting this comment after trying it with another cable. Results are the same.

Ok. Well, the next thing is to determine which side is having the speed issue.

Try connecting a computer directly to the cable instead of the dumb ap. Does that establish a gigabit link and get full internet speeds as expected?

Will that even work? because I have configured vlans and you can see in my settings in the main post.

For me, if I connect the vlan lan cable directly to the laptop, it does not detect the connection, I believe it is because of my vlans settings, I may be wrong. But if I connect it back to the AP I get full speeds like main router. This is expected behaviour because this is similar to a reboot of the AP. Like mentioned in the main post, the speeds go back to 95up/down after sometime and this has been observed before by disconnecting & reconnecting the vlan cable or rebooting.

Doe your laptop have the ability to configure VLANs? You're right, it will be hard to test with tagged VLANs configured on the router unless your laptop can be configured to use tagged networks, too. (this is quite easy on a mac, for example, but I've never tried on Windows, and linux can be a bit annoying, depending on the distro).

I have a windows laptop and unsure how to do it on windows.
I hope someone looks up this issue and helps/guides me

One thing you could do would be to untag one of the networks... the windows machine will just ignore the tagged network.

I changed one of the networks as untagged like you mentioned and I am getting only 95up/down on the laptop.

https://imgur.com/a/o2S2LhI What I have changed from tagged to untagged is circled in red. This is in the main router.

So that suggests that the main router is having an issue with the speed (or the cable). This could be a physical issue with the port (debris or bent pins), a cable problem, or possibly something wrong with the device itself (failing internal hardware), unless there is a software/driver issue that is causing it to fall back to 100M speeds.

Don't forget that if you're dealing with any additional cabling/terminations (such as a patch panel, couplers, jacks, etc.), these are all part of the 'cable' equation.

No I think this is something to do with vlans. As soon as I untag and connect the lan cable to the usb c dongle becomes 100FD on the main router. This is seen in the image. But if I connect it to the AP it becomes 1000FD and I get full speeds for sometime and then falls back to 95up/down. Also my dongle is gigabit dongle.

I am sorry to say this but please do not guide unless youre sure and can comprehend the vlan configuartions I have posted. This device was working perfectly on 22.03. Only after I upgraded to 22.03.2 I am facing this issue on the AP. Its easier to say hardware is failing, dust etc than finding the root cause

I don't think so, personally. The physical link speed is just that -- physical. It happens at L1. Everything with VLANs and general switching happens at L2. So, if it is a problem with the VLANs, that would actually suggest a driver issue or something very low level that is misbehaving.

But sure, if you believe that the VLANs are to blame, we can work to see if that is the problem. Just remove the VLANs from the configuration (for now -- save a backup of your current config and you can restore it easily when we're done).

This still suggests a physical (L1) issue. Or, more accurately, it does not rule out a physical issue.

I don't really like to 'pull rank' here, but I'd recommend that you look at the forum users list (hamburger menu in the upper right hand corner), then select "all time" and sort by "solutions" -- I'm quite well versed in VLANs and OpenWrt.

Suggestion: roll back to 22.03 (.0? -- whatever version was working properly) and see if that resolves the issue. Maybe a driver level issue has emerged in the upgrade.

Let me give you a similar example... I have a network rack with a patch panel. All the devices that are physically located in the rack used these couplers. Over time, those couplers actually start to fail (even if the cables are never moved). Initially, you may get a gigabit connection, but it will fail back to 100M sometime later (could be seconds, could be hours or days)... I don't know exactly why this happens (thermal, micro-movements caused by vibrations around the house, etc.), but it is a purely L1 issue. Removing those couplers solved the issue. And it turns out that the couplers get really bad reviews for this very issue (which I only noticed when I was looking to replace them after having found some that had failed; I had thought mine were an uncommon failure until I looked at the reviews).

In addition to being well versed in VLANs, OpenWrt, and other networking things, I am also an electrical engineer... I've seen all sorts of odd things happen with networks, and when you have problems like this, you need to start at first principles -- L1 (phy) is the start of that. And until we can prove that the hardware is working properly, we must assume that it could be a variable. Yes, it is possible that it is related to the 22.03.2 upgrade, but it may not be... so let's try to eliminate the variables and identify the ones that need further consideration.

@mans - have you made any progress in identifying the culprit?

  • bad cable/port/terminations/patch panels, etc.?
  • OpenWrt version?
  • VLANs vs none?
  • other things?

like @psherman states it sounds like the initial link is GE but as soon as data is transmitted over the wire at gigabit speeds it immediately falls back to FE due to L2 renegotiation. Something is flaky in the chain.

the TCP/IP stack in Windows cannot do VLAN tagging by itself. Windows relies on the H/W itself to do VLAN tagging. If your H/W driver cannot be configured for 802.11q tagging then you can't do VLANs on Windows machines. You can overcome this shortfall by installing virtualbox on your windows dekstop and then install your favorite linux distro into a VM and bridge the adapter to the Windows adapter and use linux tcp/ip stack for VLAN tagging instead.

Hi @psherman . I am sorry and I understand you are trying to help me. I have ordered a LAN cable and it is going to take another week to get delivered. Once I get it, I will test it out and keep you posted if it is a physical cable issue. Also to be clear, I have no couplers in my lining, just a thick cat6 cable

Sounds good. Let us know what happens.

@psherman Hi! After late delivery and extensive testing, I can confirm the issue was with lan cable. I replaced the entire 20 meter cat6 and it works. Thank you so much for your help from the bottom of my heart!