Low speed on Dumb AP over LAN


I'm using two TP-Link routers.
Archer C7 v5 is the main one (connected to WAN).
TL-WR841N v9 is configured as Dumb AP and located at opposite end of my apartment.
Both routers are connected with an Ethernet cable between LAN<->LAN ports.

Now I noted slow speed on a secondary router, no matter over Cable or Wi-Fi.
My ISP provides me 100 Mbps download, but on the secondary router, I can barely get 25-30 Mbps. Measurement with iperf3 between the secondary router and the main one gives me around 75-77 Mbps, which is still far from 100 Mbps the secondary router is capable of (counting the fact I'm trying to measure only LAN speed, so it should be like 94-96 Mbps with 100baseT port).

And one more interesting fact - not so long ago I changed the main router. Before, TL-WR841N was the main one (which is the secondary now). And another TL-WR741ND was secondary. And in this setup everything was perfectly fine, I could reach almost the same speed on the secondary router as on the main one.

So, looks like there is definitely something about the relation between the new router (Archer C7) and the old one (TL-WR841N).
But I have no idea how to troubleshoot this.

I think the fact the new router has 1 Gbps port (8 pin) vs 100 Mbps port (4 pin) for the old one should not cause such an issue and LAN speed between them should be limited to the slowest one - 100 Mbps.

Archer C7 v5 is running on OpenWrt 21.02.1
TL-WR841N v9 is running on LEDE 17.01.7
TL-WR741ND v4 (formerly) was also running on LEDE 17.01.7

Any ideas on how is that possible - everything is running smoothly with no issues but looks like the LAN connection is capped somehow? And everything was nice with the pair of two old TL-WRXXX routers. The cable or any in-between parts are left untouchable.

If needed I can share my configs, but nothing outstanding there. The main router has a pretty default configuration in terms of interfaces/networks (+software offloading). The secondary one is configured exactly as described here https://openwrt.org/docs/guide-user/network/wifi/dumbap.

upd. When I connect my laptop directly instead of a secondary router I can get the full speed of around 100 Mbps. But when connected through Dumb AP the connection gets capped.

I am in the process of a similar setup.
@psherman gave me the wonderful configuration change which you may find helpful: What terminal commands should I execute to understand why WAN connection fails after disabling the firewall? - #6 by psherman

From what I can recall, the configuration suggestions in my thread differ from the wiki page.

Are you testing iPerf running on the routers in question? This is not necessarily representative of the speed through the hardware, since the routers may not have CPUs with enough bandwidth to source/sink the traffic at line rate (whereas it may be able to switch and/or route traffic through the device at higher speeds).

The best way to test is to use client systems that are much more powerful such as a regular computer. The iPerf should run from one system to the other on the same LAN, so basically one wired computer connected to the C7 and another one connected to the WR741Nv9. Start wired-to-wired, and then try again using the WR741Nv9 wifi.

These two routers should be thrown away (recycle/ewaste) and replaced. LEDE 17.01 has many known vulnerabilities, including the KRACK vulnerability that was discovered in 2017. At the very least, they should be running a newer version (18.06 is the latest supported), but even in this situation, there are known security issues and that version is unsupported and obsolete. And even if you choose to disregard the security concerns, as far as performance goes, those devices have old wifi hardware that may be the limiting factor here in terms of bandwidth.

Sorry, don't see how this can be helpful to my case.
All this configuration change does - assigns WAN port to your LAN network, so basically now you have [0 WAN / 5 LAN] ports instead of [1 WAN / 4 LAN].
Maybe it is useful when you need +1 port on Dump AP, but it has nothing to do with the described problem...

1 Like

No, I was testing on my laptop connected to the main router vs raspberry pi connected to the secondary router. So CPU cycles of routers were not involved.

I know, that's why I'm using it only as Dump AP to extend Wi-Fi coverage. Upgrading to 18+ is not suitable due to very limited device memory. I can't install any package additionally with these versions.

But you're still vulnerable to major vulnerabilities.

What packages are you installing on a dumb AP?

Yep, and I'm okay with this for now... This is used primarily for one Wi-Fi surveillance cam watching the street, so hackermans may sniff it if they like. No real usage or sensible data is walking around there.

For example, zabbix-agent and related, as I have monitoring set up.

Still, despite the fact, LEDE 17.01.7 is deprecated and vulnerable I had no issues with speed between two such routers before...

They could also compromise your entire network and take down your camera, if they want.

So, there is very little in the configuration that can affect the speed of the connection on the switch.

Have you tried testing between two wired computers connected to the 841N?

I will consider this later, but now the speed limit is a more annoying problem... And this is not related to the firmware version directly.

Nope. Only between devices connected to different routers and when replaced the second router with laptop. Will try this also and reply a bit later. Thanks for helping.

Ok, I tried now with two laptops. Got 100 Mbps while connected to 841N. Also got 100 Mbps when connected to different routers. So the LAN itself looks perfectly fine.

But still, the speed test on 841N shows around 20-30 Mbps... Kind of magic.
How to troubleshoot further?

Your WiFi speeds will inherently be limited by the old 802.11n hardware. But post your config info and we will look at that.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless

But the point is the INTERNET speed is limited EVEN when I connected with cable to 841N.
LAN speed is perfectly fine for both Wi-Fi and Cable (also it worked just fine with two old routers).
So this is not a hardware limitation, nor a wireless problem (for simplicity let's assume we are talking only about cable connection now).


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix '****:****:****::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option ipaddr ''
	option gateway ''
	option broadcast ''
	option dns ''

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option country 'UA'
	option channel '13'
	option htmode 'HT40'
	option noscan '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option encryption 'psk2+ccmp'
	option key '********'
	option ssid '********'

Is that possible to be happening because of NAT offloading enabled on the main router?
841N does not support this feature as it appears only in 19.07 or something.

At first glance, this makes sense because the feature comes in when NAT is happening.
So in LAN no issues, but attempts to access WAN result in issues.
Also, there was no such a feature on the old router, so everything worked just fine together.

However, I'm not sure how things are working for Dumb AP, whether it should also support offloading if the main router has it enabled. Or (more likely) all the packets are going to the main router as is and it processes everything, so it does not matter what Dumb AP supports on not.

Ok... so try this:
Move the 841N so that you can use a short, known good cable between it and the C7. Then test again.

The 841N doesn't care about NAT offloading... if it is a dumb AP, it is just another device on the network, and it doesn't have to know about or care about what is happening on the C7. Your speed should be limited only by the 100Mbps uplink between the two devices or the wifi capabilities.

But the laptop shows a perfect 100 Mbps speed test over the same cable...
Also if LAN speed is 100 Mbps, but internet speed is low, there is no possibility for faulty cable.
Well, will try some more tests tomorrow and post my findings.

It is still worth testing. I agree that it doesn't really make sense, but stranger things have happened.

If you connect the laptop to one of the other LAN ports you should get good speed. [In its default configuration with OpenWrt] the four LAN ports are hardware switched together and do not depend on the software in the 841 at all. The hardware switch is always as fast as the 100 Mb Ethernet link.

The WAN port of an 841 is a separate path to the CPU, so should you add it to the LAN bridge it still will need some CPU time on each packet for LAN-LAN transfers where one of the ports is the blue WAN port. So when setting up a dumb AP and bridging all the ports, use the blue WAN port for a device that won't have heavy traffic.

I know this, and this is not related to my case as the routers are already connected between LAN<->LAN ports. I'm getting a good speed but only for the local network.

Did some more tests (all wired). Here are the results:

100 Mbps: Laptop1 --- [LAN|841N|LAN] --- [LAN|ARCHER|LAN] --- Laptop2
100 Mbps: Laptop1 --- [LAN|841N|LAN] --- [LAN|ARCHER|WAN] --- Laptop2

20-30 Mbps: Laptop1 --- [LAN|841N|LAN] --- [LAN|ARCHER|WAN] --- Modem
100 Mbps: Laptop1 ------------------------ [LAN|ARCHER|WAN] --- Modem

As you can see from the scheme, I even tried connecting Laptop2 to the WAN port on Archer instead of Modem (assigned another range to WAN and set up IP addresses manually) to emulate the real internet connection with NAT, etc. and did the same iperf3 test between them. And even in this case iperf3 gives me perfect speed.
But as soon as I measure the real Speedtest it is limited to 20-30 Mbps...

upd1. Just tried upgrading 841N to 18.06.9, configured as Dumb AP from scratch. The same nonsense... 20-30 Mbps.

upd2. Found a very similar issue here. Also the same speed limit around 20-30 Mbps (but only Wi-Fi) and nothing helped.

I run out of ideas, this is something unexplainable...

Tried another router as a secondary with exactly the same configuration - everything works flawlessly.
I can't explain it and I think we'll never know why, but looks like Archer C7 v5 and TL-WR841N v9 are kind of incompatible...
The topic can be closed.