Low RF Output Configuration

I'm trying to configure OpenWRT on a Netgear WN3000RPv3 as an access point with minimal RF output.

I've increased the Beacon Interval to 10000. However, an RF meter detects a pulse every 2 seconds (which disappears when the AP is turned off).

Would this 2 second pulse be the beacon? (which should be 10s?). Is there a way to disable the beacon entirely? I've tried disabling the ESSID but that doesn't make a difference.

Beacon interval values higher than 10000 (10001 and higher) result in the wireless not working at all.

Also AP works for a few minutes and then is not contactable at all either via Wi-Fi or ethernet without restarting.

Wireshark on a monitor interface will tell you what it is.

Considering you're way outside the range of expected operation of beacon frames (100 ms is typical), it's possible you're running into number-representation problems or have violated some other assumption of rationality in the code.

See https://mrncciew.com/2014/10/08/802-11-mgmt-beacon-frame/ for some more information on beacon frames and their timing and contents.

Of particular interest

  1. Beacon Interval (2 byte)
    Beacon Interval field represent the number of time units (TU) between target beacon transmission times (TBTT). Default value is 100TU (102.4 milliseconds)

2 bytes = 65536 * 1024 ┬Ás seems to be the longest beacon that can be represented.

what happens if you lower them under 1024ms?

Running Wireshark shows that it is sending a Beacon Frame every 2 seconds, although interestingly in the frame itself it indicates that the beacon interval is 10.24 seconds.

Lowering the beacon Interval to 1000 sends it every second.

hostapd has a configuration option start_disabled=1 to disable the beacon, however this option is not available in /etc/config/wireless. Is there any way to pass through hostapd options using the /etc/config/wireless file?

I tried to find the script which generates the /var/run/hostapd-phy0.conf file but couldn't find it.

Small update, it turns out start_disabled can be put into /etc/config/wireless, it needs to go into the 'config wifi-iface' section. However, this turns the radio off altogether, which means that it is not possible to connect to wifi.

Looking into this further I don't think it is possible to disable the beacon without using a vendor-specific command, if the chipset supports it.