Low Mesh channel speed

Hi,

I have a speed problem with my mesh setup.

The mesh chanel show very low speed rates (6 Mbit/s)


It seems that, despite supporting higher speeds, the connection is limited to 6 Mbit/s

and this is a iperf3 test between the two routers

iperf3

Is there something in the setup that I am missing?

How would we know? You have not told us anything about your mesh setup.....

You could try some background reading:

This is my wireless setup

root@OpenWrt:~# vim /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wmac'
        option band '2g'
        option htmode 'HT40'
        option cell_density '0'
        option country 'ES'
        option channel '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wmac+1'
        option band '5g'
        option htmode 'VHT80'
        option channel '60'
        option country 'ES'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'mesh'
        option encryption 'sae'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option mesh_id 'cggm-mesh'
        option key 'meshpass'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Salon'
        option encryption 'sae-mixed'
        option key 'salonpass'
        option ieee80211r '1'
        option mobility_domain '4ee6'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Domotica'
        option encryption 'psk-mixed'
        option key 'domopass'
        option ieee80211r '1'
        option mobility_domain '4ee6'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Salon5'
        option encryption 'sae-mixed'
        option key 'salon5pass'
        option ieee80211r '1'
        option mobility_domain '4ee6'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan'

This is the mesh interface

root@OpenWrt:~# iw dev phy1-mesh0 info
Interface phy1-mesh0
        ifindex 10
        wdev 0x100000002
        addr xx:xx:xx:xx:57:ca
        type mesh point
        wiphy 1
        channel 60 (5300 MHz), width: 80 MHz, center1: 5290 MHz
        txpower 20.00 dBm
        multicast TXQ:
                qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-p                                                                                                                                                 ackets
                0       0       6217    0       0       0       8       1005302         6399

The problem is that the TX rate in the "master" and the RX rate in the "client" are set to 6.0 MBit/s. ¿How can I change this?

Show the output of:
iw dev phy1-mesh0 scan | grep -B 35 "MESH ID:" | grep "signal"

This should list the signal strengths of any mesh nodes within range.

signal: -48.00 dBm