Lost Wireless option in network panel after reset of DSL 2740B

Hello everyone :slight_smile: , I'm new on forum and I'm also a noob in router modding :grin:

I have an old D-Link DSL2740B F1 EU that I would convert to a wireless network repeater.
I installed first time with success Open WRT 18.06 but after some bad configuration (Wifi network as repeater), I couldn't connet to the router.
I've resetted the modem and I've lost the "wireless" option in the "network" panel of the LuciGui (also the file wireless in etc/config is gone)
I've tried to search and follow the solutions in similiar thrads but it didn't helped.
I've also tried to flash back D-link original firmware (wifi started to working again) and then OpenWrt one again but nothing.
Now I've installed via D-link emergency flash mode LEDE 17.01.05 version but still no wifi and still no wireless file in config directory.
What can I do?

Thanks in advance and Merry Christmas :grinning:

Make sure that you have kmod-ath9k installed (maybe also kmod-owl-loader), also check dmesg for error messages regarding your wlan cards and debug it further using iw and iwinfo.

Have you tried wifi detect -> /etc/config/wireless? In some cases it may work to recreate the wifi config file.

Try this , opkg update && opkg install wireless-tools wpad-mini

Ok, kmod-ath9k was already installed, I've installed kmod-owl-loader
dmesg gave me various messages where I think some of these are errors:

[    0.000000] Initrd not found or empty - disabling initrd
[    0.104761] Can't analyze schedule() prologue at 80016d88
[    0.406072] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.497136] pci 0000:01:00.0: invalid calibration data
[  462.180510] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
[  462.188377] owl-loader 0000:01:00.0: Direct firmware load for ath9k-eeprom-pci-0000:01:00.0.bin failed with error -2
[  462.199272] owl-loader 0000:01:00.0: Falling back to user helper
[  462.533824] firmware ath9k-eeprom-pci-0000:01:00.0.bin: firmware_loading_store: map pages failed
[  462.543291] owl-loader 0000:01:00.0: no eeprom data received.

if I type iw wlan0 info, I receive an Help Guide on how to use the iw command .


Tried the command and I've got a wireless file in etc/config but it's blank


Tried and it has installed some packages but didn't change nothing

Could you show us the output of


Wifi config


root@LEDE:~# iwconfig
br-WAN    no wireless extensions.

eth0.1    no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

br-lan    no wireless extensions.

wifi config doesn't do anything wificonfig gives error command not found

root@LEDE:~# wifi config
root@LEDE:~# wificonfig
-ash: wificonfig: not found

So as iwconfig output there is no wifi interfaces . May you disable wireless by pressing button on router ?

Wifi config create wireless config file

What firmware did you install first? Where did you download it from?

With original D-link firmware the wifi on/off button works, with first installation of openwrt 18.06 worked but now it doesn't work with each version of openwrt.

The wireless file in etc/config is a blank document


This: openwrt-18.06.1-brcm63xx-generic-DSL274XB-F1-squashfs-cfe-EU.bin from this page: https://openwrt.org/toh/d-link/dsl-2740b?

my wifi broke completely with openwrt and original d-link after flashing:

go back to d-link http://files.dlink.com.au/products/DSL-2740B/REV_F1/Firmware/Firmware_v2.04_(26-07-2012)/DSL2740B_F1_AU_2.04_07262012.bin

and you have working wifi again, and you can use it in openwrt.
somehow openwrt deletes important flash memory in 2nd update and only very old d-link firmware can restore it.

btw. i have eu Version, no Australia. but works also.

look also Wifi AR922x not detected after upgrade 18.06 - #23 by Turrican similar problem

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.