Lost network share after upgrade to 21.02.2

DIR-2660 A1 with OpenWrt 21.02.1 was working fine with all required packages for network share.
After upgrading to 21.02.2 i can't see Netowrk Share.
While upgrading by default checked to keep the settings.
Is it possible to restore all required packages and other settings.
I'm using both USB 2.0 and 3.0 with FAT and NTFS file system on USB drives.
I did not note which packages were installed
Any help for easy restore or at least which packages needed.


Typically you need to install the kmods for the filesystem(s) you are using as well as the packages for the file sharing protocol such as samba.

This article might help:

In the future, you can use the attended sysupgrade to make the process easier, or you can just keep track of the packages you have installed so that you can re-install them manually with little effort.

sysupgrading (without using auc or handcrafted images from imagebuilder) removes your runtime installed packages, but retains the configuration. So you basically just need to reinstall those (e.g. samba or ksmbd) package and it should start working again.

I tried to install samba4 got error, then tried luci-app-samba4 again got error.
What is the issue here space or package? not sure

Collected errors:

  • verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg samba4-server needs 223
  • opkg_install_cmd: Cannot install package luci-app-samba4.
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.8M      3.8M         0 100% /rom
tmpfs                   123.1M      1.1M    122.0M   1% /tmp
/dev/ubi0_1              24.3M     16.9M      6.1M  73% /overlay
overlayfs:/overlay       24.3M     16.9M      6.1M  73% /
tmpfs                   512.0K         0    512.0K   0% /dev