Lost https web UI access

Openwwrt: OpenWrt 21.02.0-rc4 r16256-2d5ee43dc6 / LuCI openwrt-21.02 branch git-21.314.39479-e1ccb66
used for months.. suddenly I am totally unable to access the https:// web interface.
http:// is available and works.
I cant figure out what happened.
The only thing I have done somewhere around that time (but I cant relate to it) is trying squid proxy.
So after loosing https:// access to my Luci UI, I decided to uninstall Squid proxy.
However, I did not regain my https:// access
Can someone help me trouble shoot this?
Additional info:

  • I tested the https:// access using several different devices and is always the same issue. So is not device related.
  • it is not an upgrade from previews Luci versions
  • Luci runs on a Netgear Nighthawk X4S R7800
  • I do have a second router in my LAN also with Luci configured as a dumb AP. (to know I have that from the beginning and cant really be the cause of the issue. It has been working all fine till some days ago)


What happens if you install 21.02.1 instead of the old rc4?

I was just looking to see if there is an ungrade available.. you are fast :slight_smile: .
Thanks for the reply. Will get back to u soon

Squashfs sysupgrade, right?

upgrade done.
same thing. no https://
Actually is worst... http:// redirects to https:// and I cant access the UI all together now!
I can access with http:// my FF was set to only accept https:// connections. other browser allows http:// unsecure connection.
any idea how to trouble shoot that?
Mind that is my router right after the fiber optic from ISP.
So if I take that down, I have no internet.
No other router before it.

so, I tested an earlier configuration backup.
and noticed that https:// was than working again.
I use linux and have installed also Chrome on linux. I realiazed that Chome was letting me in with https:// with warnings.
But FF not at all.
got my newer configuration back, cleared cache in FF and my https:// was back.
Note that before upgrading the openwrt, I had cleared cache but no joy.
The upgrade DID solve my issue.
It would be still very good to know what beak my earlier https://
I guess we can call this case solved!

I get this problem every time I install or upgrade anything luci-related on my x86 router

got a bad surprise I did not noticed yesterday... my openvpn client to PIA is gone. All related VPN packages are no longer there.
I will try to restore an older configuration ....

anyone knows how to reset the old config with openvpn and vpnbypass without I go to the all configuration again?
all the folders are back but all services are not.
I am trying to reinstall them with the hope they will pickup the config that seems to exist.. not sure I lost some parts along the upgrade
It appear that after reinstalling the services, the configuration (that was backed up) is back and dont need to re-configure everything.
The process of reinstalling the services is quick after all.
Now I would love to know how to prevent this to happen to the next upgrade of LUCI
any suggestions?
Maybe some lines under the System -> backup -> configuration tab????

I have found it more functional to go directly to the router IP address in webbrowser address line. Often if a bookmark is used it is saved with some dns text for luci after the ip address.
If all that is removed and only https://“ip address” is called it usually works.

Hi @flygarn.
thank for the feedback. I always use the ip address in the browser address line.
but that is now solved.
The discussion is now related to the after math... maybe I should open a new topic.
Sorry about that

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.