Lost connectivity to OpenWrt GUI

Hi. Easy question. Just too hard for me because I’m kind of stupid.

So I changed the default LAN address to access the router GUI from to (let’s just say that it was this address). Aside from this MR8300 router that I have which has OpenWRT installed, I have the providers router sitting between the Internet and the OpenWRT router. This address is Now, as expected, I can no longer access the GUI. Here are some things that I’ve tried…

  • I’ve tried putting the computer on the same subnet as the newly set address, to no avail.

  • I tried another computer that is directly connected to the router, but that doesn’t work either.

Now, some errors that may provide further insight include:

  1. Once the changes were saved and applied, I’ve been stuck on this page that says “Failed to confirm apply within 90s, waiting for rollback…”

  2. I visit and the top of the page is headed with LuCI- Lua Configuration Interface, but there is no login page.

  3. I visit but the page is unreachable.

  4. Interestingly, my Wi-Fi network still works and so does the wired connection between my main PC and the Internet.

Here are some specs that might help with correcting the problem:

  • The router is a Linksys MR8300 Mesh Wi-Fi router.

  • The OpenWRT image is OpenWRT-19.07.4-ipq40xx-generic-linksys_ea8300-squashfs-factory.bin

  • I haven’t shutdown the router

  • I haven’t set up SSH on the thing either

Thanks for reading. Any advice on what to do?

LuCI has some kind of failsafe that probes for connectivity. The easiest way to achieve what you want would be to do this (given that your LAN IP is

# sed -i 's|||' /etc/config/network
# /etc/init.d/network restart

Then disconnect your client if your router hasn't done so yet, and reconnect.

That should help to gain access again, afterwards you should be able to follow Borromini's advice.

1 Like

Awesome! So I did a factory reset on the MR8300 and it worked! Got me back to accessing the GUI using However, does this mean that now both partitions are OpenWRT and that I can no longer roll back to the manufacturer's GUI?

Thanks for your reply. So now that I have access to the GUI I'd still like to change the default IP address. This is the only way of changing it? Through CLI?

No you can still go back. 3x10 method.

Here's another thread on the MR8300.

My command line skills are weak or non existent. I am new to linux and the OpenWrt environment. Fortunately, kindly developers and other thoughtful people created LuCI.

LuCI-->network-->interfaces-->LAN-->edit-->ipv4 address-->save-->click on the arrow to the right of save and apply-->select apply unchecked-->click on apply unchecked-->wait 10 seconds-->navigate to new IP address

Learning how to apply unchecked is necessary to prevent the router from going back to the original IP. If you can log in to the new IP before it times out you don't have to do this.

Also alot of users are having problems with web browsers caching - which interferes with logging into LuCI. Clear your browser cache. Disable auto complete. Allow http and https addresses. Firefox still autocompletes alot of the time with https - the LuCI webpage is http.

You might have to restart your NIC as well as it may not accept the address.

Thanks! I appreciate the input. If anything, I can just do another factory reset.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.