Lost 5/6g Wifi after updating OpenWRT

After updating OpenWRT on my Bananapi R4 with an AW7916-NPD wifi card a few days ago (which I generally do at least once every couple weeks) I no longer have my 5g/6g bands. The wireless config still all looks right, LuCi shows them broadcasting but shows 91dbm and "No client associated" for both bands and the bands aren't actually showing up on any device or wifi-scanning app. The blob from before and after updating only has two differences:

  1. MT-7916e is gone (but the MT7916/MT7915 drivers/firmware still show

  2. wpad-basic-mbedtls is gone (it was not actually installed, instead I use OpenSSL, it was just listed, it was a bug).

LSmod:

lsmod | grep mt7996
cfg80211              311296  5 mt7996e,mt7915e,mt76_connac_lib,mt76,mac80211
mac80211              602112  4 mt7996e,mt7915e,mt76_connac_lib,mt76
mt76                   69632  3 mt7996e,mt7915e,mt76_connac_lib
mt76_connac_lib        49152  2 mt7996e,mt7915e
mt7996e               118784  0

The before blob:

owut blob
{
  "client": "owut/2024.08.09~8a6becd8-r1",
  "target": "mediatek/filogic",
  "profile": "bananapi_bpi-r4",
  "version": "SNAPSHOT",
  "version_code": "r27334-a66f6c1bfb",
  "filesystem": "squashfs",
  "diff_packages": true,
  "packages": [
    "mkf2fs",
    "wpad-basic-mbedtls",
    "kmod-mt7916-firmware",
    "kmod-mt7996e",
    "busybox",
    "kmod-hwmon-pwmfan",
    "nano",
    "openssl-util",
    "kmod-phy-marvell",
    "kmod-phy-aquantia",
    "procd-ujail",
    "base-files",
    "libustream-mbedtls",
    "fitblk",
    "firewall4",
    "pciutils",
    "uboot-envtools",
    "dnsmasq",
    "procd",
    "usbutils",
    "hostapd-utils",
    "kmod-rtc-pcf8563",
    "kmod-usb3",
    "kmod-phy-realtek",
    "kmod-eeprom-at24",
    "wpad-openssl",
    "kmod-sky2",
    "odhcp6c",
    "ethtool",
    "uci",
    "luci-ssl",
    "dropbear",
    "mtd",
    "odhcpd-ipv6only",
    "procd-seccomp",
    "kmod-crypto-hw-safexcel",
    "kmod-mt7915e",
    "kmod-i2c-mux-pca954x",
    "urandom-seed",
    "ppp",
    "kmod-leds-gpio",
    "kmod-gpio-button-hotplug",
    "kmod-sfp",
    "kmod-mt7996-firmware",
    "logd",
    "e2fsprogs",
    "ca-certificates",
    "f2fsck",
    "ca-bundle",
    "luci",
    "owut",
    "kmod-phy-marvell-10g",
    "wireless-tools",
    "urngd",
    "ppp-mod-pppoe"
  ]
}

The new blob:

# owut blob
{
  "client": "owut/2024.09.07~6564aa2a-r1",
  "target": "mediatek/filogic",
  "profile": "bananapi_bpi-r4",
  "version": "SNAPSHOT",
  "version_code": "r27346-c7ba5574f5",
  "filesystem": "squashfs",
  "diff_packages": true,
  "packages": [
    "mkf2fs",
    "kmod-mt7916-firmware",
    "busybox",
    "kmod-hwmon-pwmfan",
    "nano",
    "openssl-util",
    "kmod-phy-marvell",
    "kmod-phy-aquantia",
    "procd-ujail",
    "base-files",
    "libustream-mbedtls",
    "fitblk",
    "firewall4",
    "pciutils",
    "uboot-envtools",
    "dnsmasq",
    "procd",
    "usbutils",
    "hostapd-utils",
    "kmod-rtc-pcf8563",
    "kmod-usb3",
    "kmod-phy-realtek",
    "kmod-eeprom-at24",
    "wpad-openssl",
    "kmod-sky2",
    "odhcp6c",
    "ethtool",
    "uci",
    "luci-ssl",
    "dropbear",
    "mtd",
    "odhcpd-ipv6only",
    "procd-seccomp",
    "kmod-crypto-hw-safexcel",
    "kmod-mt7915e",
    "kmod-i2c-mux-pca954x",
    "urandom-seed",
    "ppp",
    "kmod-leds-gpio",
    "kmod-gpio-button-hotplug",
    "kmod-sfp",
    "kmod-mt7996-firmware",
    "logd",
    "e2fsprogs",
    "ca-certificates",
    "f2fsck",
    "ca-bundle",
    "luci",
    "owut",
    "kmod-phy-marvell-10g",
    "wireless-tools",
    "urngd",
    "ppp-mod-pppoe"
  ]
}

I'm not sure what else might be helpful/needed, but happy to provide anything needed to help troubleshoot this. I don't really want to start over and can't revert as soon I'm installing a new WiFi card (the BE14 WiFi 7 card) and need the latest (well 2nd latest now I believe) snapshot for the drivers but would like my 5/6g bands back until I can find the time to put the new card in and print the new case to fit it.

Adding additional logs:

~# ubus call system board
{
        "kernel": "6.6.50",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 0",
        "model": "Bananapi BPI-R4",
        "board_name": "bananapi,bpi-r4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r27352-47370eb9ba",
                "target": "mediatek/filogic",
                "description": "OpenWrt SNAPSHOT r27352-47370eb9ba"
        }
}
cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0a:8464:11d5::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'eth1'
        list ports 'phy0-ap0'
        list ports 'phy1-ap0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.57.130'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '9.9.9.11'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'
        list ports 'eth2'

config device
        option name 'wan'
        option macaddr 'xxxx'

config device
        option name 'eth2'
        option macaddr 'xxxx'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '9.9.9.11'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'
cat /etc/config/wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option channel 'auto'
        option htmode 'HE20'
        option disabled '0'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'XXXX_V2.4'
        option encryption 'sae-mixed'
        option key 'XXXX'
        option nasid 'skynet_V2_0'
        option ieee80211w '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option band '5g'
        option channel 'auto'
        option htmode 'HE80'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'XXXX_V5.0'
        option encryption 'sae-mixed'
        option key 'XXXX'
        option ieee80211w '1'
        option ocv '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+2'
        option band '6g'
        option htmode 'HE80'
        option channel 'auto'
        option disabled '0'
        option country 'US'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'XXXX_V6.0'
        option encryption 'sae'
        option key 'XXXXX'
        option ocv '0'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'
cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '0'
        option ednspacket_max '1232'
        option localuse '0'
        option logdhcp '1'
        option logfacility 'USER'

config dhcp 'lan'
        option interface 'lan'
        option start '131'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Printer'
        option mac 'XXXXXX'
        option ip '192.168.57.146'

cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Allow-HTTPS'
        option src 'wan'
        option proto 'tcp'
        option dest_port '443'
        option target 'ACCEPT'

@Ansuel mentioned on irc: "it looks like there was a backport for mtk packages and the wifi package got split in 2 package, one for the driver and one for the firmware. On updating to the new stable release user have wifi broken as the firmware package is not installed".

Try opkg install kmod-mt7996-firmware and see if that does anything...

No luck, says it's already installed and up to date.

Unfortunately no change. It seems it's in the latest (.51) kernel as it required me to update to that to install it, then showed it installed after the update.

Sorry to bump this but still haven't figured it out, anyone have a direction to point me or is there any other info I should post that might shine a light on the problem? I tried doing a restore to a backup I had from 3 weeks ago prior to this, no errors but it also seems to not take, kernel stays the same and no change to functionality.