Loosing Windows Internet connectivity

Hi there.

The rig:
I have 2 routers running LEDE 17.01.3 on a "seamless" wifi network (same SSID/password with different wifi channel) but this has happened on earlier releases of LEDE and it even happened with OpenWRT before I moved to LEDE.
For the record, the secondary router has dnsmask, odhcpd and firewall disabled permanently.

The problem:
All works great for periods of time but once in a while I loose Internet access on my laptop, meaning I get a full Wifi network signal but with a yellow exclamation mark.
If I open a CLI I can't even ping the router's internal LAN IP address or any other device on the network.
This doesn't seem to happen on other devices like mobile phones/tablets, appears to be a problem only on this PC that's running Windows 7 Pro. But I could be wrong. I mean, Android devices are known to deal with wifi roaming a whole lot better than Windows and for that they usually simply reset the interface and re-authenticate.
Sometimes this can happen in a matter of minutes (like every 5 or 10 minutes for a whole day) but sometimes it takes many hours to happen again.
For the record, today it's been very bad with this issue. This has happened 4 or 5 times while I was writing this message.

The temporary solution:
Just disconnect from that particular Wifi SSID and reconnect back again. Hence why I am not particularly sure that this is not happening with any other devices, since these Androids are very good at disconnecting/reconnecting/authenticating in a matter of 2 or 3 seconds...

My questions:
Is there a way for me to debug this?
Could this be a simple misconfiguration on my end?

Here's the cat /etc/config/network and cat /etc/config/wireless for both routers:

Main router (with firewall/DNS enabled):

Network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd30:74bf:8f61::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.11.11.1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'rdscAP'
        option encryption 'psk2+ccmp'
        option key 'my_wifi_pwd'

And here's the same for the secondary router in "AP mode":

Network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc0:2487:f87c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.11.11.2'
        option gateway '10.11.11.1'
        option dns '8.8.8.8 8.8.4.4'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option htmode 'HT20'
        option country 'US'
        option channel '6'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'rdscAP'
        option encryption 'psk2+ccmp'
        option key 'my_wifi_pwd'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:12.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'LEDE'
        option encryption 'none'

I don't see anything obviously wrong with that. Pretty similar as my own config.

I experienced something similar with a Windows phone, and I guess that it did not like roaming from one router to the other.

But I started to use ieee802.11r fast transition roaming, and have not seen the problems lately.

You might look into using 802.11r

1 Like

But I don't think it's a matter of roaming. Well, just a hunch because I don't have evidence.
I'm saying it might not be roaming because I have the PC at the same place for hours and it stands right next to the main router.
The secondary router that I use as a simple AP is maaany feets away from this place.
But this leads me to one of my questions: how do I debug this issue? How can I find logs that can show me this kind of issue.
For the record, stuff connected to ethernet ports on the router doesn't show any such problem.
Oh, and I've tested the roaming with the PC on numerous occasions and the truth is it doesn't work. It never looses signal from the main router unless if I restart the wifi adapter.
But even on those occasions I've never experienced this kind of issue that I am mentioning.
OTOH, Android devices are like fish in the water roaming from one AP to the other when needed.

Since your network is IPv4, make sure your IPv6 DHCP server is turned off in both routers (in /etc/config/dhcp). Windows in particular doesn't like being told there's a V6 router, but it actually goes nowhere.

Setting "ignore" only affects v4. You have to turn off v6 separately.

1 Like

But that would only happen on IP renewals and, I know this isn't my expertise but, when a PC is running and already has one IP, I don't see why it would be given another one...
But that's me, I'm a complete ignorant when it comes to DHCP.
I will turn DHCP off for IPv6 ASAP.

Well, I went to disable DHCP in IPv6 but didn't find where to do it.
Here's a cat /etc/config/dhcp:
root@rdscAP1:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option limit '50'
        option ra_management '1'
        option start '40'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'po1603vm'
        option leasetime 'infinite'
        option mac '08:00:27:01:c4:3f'
        option ip '10.11.11.20'

config host
        option leasetime 'infinite'
        option name 'pi3sala'
        option mac 'b8:27:eb:86:cb:fb'
        option ip '10.11.11.10'

config host
        option leasetime 'infinite'
        option name 'po1603'
        option mac '30:52:cb:ff:b6:fc fc:3f:db:48:4f:fb'
        option ip '10.11.11.30'

config host
        option name 'envy4500'
        option mac 'f0:92:1c:88:87:7f'
        option ip '10.11.11.9'
        option leasetime 'infinite'

Please note that there's one host with two MAC's.
That's exactly the host giving me problems. The reason for 2 MAC's is I was trying for it to grab the same IP whether on Wifi wether on Wired.

Change dhcpv6 and ra from 'server' to 'disabled'.

The two MACs to one IP seems like it could be a problem. When you lose connection, check the router's ARP table to see if it is using the wrong MAC.

1 Like

Done, done and done.
Changed both option dhcpv6 and option ra to 'disabled', and I also now have a single MAC on that permanent lease for my Win PC.
But it is still happening...
Is there no way I can look up a log and see what's happening? Do we need to be guessing?
Thanks in advance and for the support you've been giving me so far.
Cheers

PS: I am starting to believe that there's something wrong with the router's hardware, but it's only a hunch because there's no logs to look this up...

You know logread and dmesg?
Not sure if you will find something relevant there, but that's the first place to look for logs.

And you may need to turn up logging volume for hostapd/wpad to get more info about wireless handshake details.
Look into wiki for info on wireless config.

(But do not disregard the possibility of Windows wifi stack playing badly with multiple APs/routers.)

Hi there.
Sorry to revive such an old topic.
I am the OP and I haven't posted here for a while.
This issue has still been happening all this long but since I haven't been much at home it sort of transformed into a lesser issue.
Unfortunately, the past couple of weeks I've started working from home and that's when it restarted hurting a lot.
Just so you know, I've gone through at least 3 Lede/Openwrt upgrades. This issue happened with every single one of them and I am currently on 18.06.1 on both my routers.
BTW I have a TP-Link WR1043ND V2 and a Netgear WNDR3700.
Since one week ago I have gone from a single ESSID to two different ESSID's, just in case it would have anything to do with my issues.
This is now happening at a rate that can go from 1 time per hour to 3 or 4 times per hour. And I just need to disconnect from the SSID and connect back again.
I will post again soon with some logs from logread as soon as I can grab them.
Cheers

fwiw, if the problem only seems to happen with your laptop, what wifi card is fitted to the laptop and is the driver up to date?

Does the problem appear if you specifically connect to the Netgear's 5 GHz wifi configured with unique SSID ?

Well, yes, it only "seems" to happen to my laptop running windows 7. But the truth is, lately I only have the laptop, a desktop running manjaro linux but which is running on ethernet and then I have 3 android phones, and 2 android tablets.
I don't have any other wireless windows client that I can test with. Even the linux desktop doesn't have a wifi adapter for me to test with.
And how can I tell if it's not happening with the smartphones and tablets. Maybe it is but Android can workaround the issue. I am saying this because sometimes they all seem to freeze up regarding wifi comms and then they resume after a minute. So...who knows.
The wifi adapter is a Broadcom BCM943228HMB.
Windows driver versions is 6.30.223.264. When I press the update button inside the device manager it says I'm already running the latest driver version.
Hewlett Packard's web page for this laptop model, says this is the latest driver...

The 5Ghz on the netgear is near the bedrooms and so I don't usually use it for the laptop and it is mostly used for tablets and to some extent for smartphones.
I am now running 2 separate SSID's on the 2,4GHz of both routers. Don't even currently have the 5GHz of the netgear configured.
Have disabled IPv6 on windows wifi adapter options and yet it keeps happening.

Here is a copy of the logread on both routers right after experiencing the issue at 00h32.
Please note that my notebook was registered to the TP-link wifi radio at 00h32 when this happened.

TP-link logread:

Sat Sep  1 00:22:15 2018 daemon.info dnsmasq-dhcp[1430]: DHCPINFORM(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:22:15 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:22:45 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: authenticated
Sat Sep  1 00:22:45 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: associated (aid 1)
Sat Sep  1 00:22:45 2018 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:22:45 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz WPA: pairwise key handshake completed (RSN)
Sat Sep  1 00:22:45 2018 daemon.info dnsmasq-dhcp[1430]: DHCPREQUEST(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:22:45 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:22:48 2018 daemon.info dnsmasq-dhcp[1430]: DHCPINFORM(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:22:48 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:23:00 2018 daemon.notice netifd: wan (1197): udhcpc: sending renew to 10.0.0.99
Sat Sep  1 00:23:00 2018 daemon.notice netifd: wan (1197): udhcpc: lease of 217.111.111.1 obtained, lease time 4680
Sat Sep  1 00:24:04 2018 daemon.info dnsmasq-dhcp[1430]: DHCPINFORM(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:24:04 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:25:50 2018 daemon.info dnsmasq-dhcp[1430]: DHCPINFORM(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:25:50 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:32:49 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:32:49 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: disassociated
Sat Sep  1 00:32:50 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sat Sep  1 00:32:53 2018 daemon.info dnsmasq-dhcp[1430]: DHCPREQUEST(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:32:53 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:33:07 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: authenticated
Sat Sep  1 00:33:07 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: associated (aid 1)
Sat Sep  1 00:33:07 2018 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:33:07 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz WPA: pairwise key handshake completed (RSN)
Sat Sep  1 00:33:07 2018 daemon.info dnsmasq-dhcp[1430]: DHCPREQUEST(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:33:07 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:33:10 2018 daemon.info dnsmasq-dhcp[1430]: DHCPINFORM(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz
Sat Sep  1 00:33:10 2018 daemon.info dnsmasq-dhcp[1430]: DHCPACK(br-lan) 10.11.11.150 30:52:cb:xx:yy:zz LAPTOPW7
Sat Sep  1 00:33:18 2018 authpriv.info dropbear[6825]: Child connection from 10.11.11.150:49254
Sat Sep  1 00:33:29 2018 authpriv.notice dropbear[6825]: Password auth succeeded for 'root' from 10.11.11.150:49254

Netgear logread:

Sat Sep  1 00:21:00 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:21:00 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: disassociated
Sat Sep  1 00:21:01 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sat Sep  1 00:21:05 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: authenticated
Sat Sep  1 00:21:05 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: associated (aid 2)
Sat Sep  1 00:21:05 2018 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:21:05 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz WPA: pairwise key handshake completed (RSN)
Sat Sep  1 00:21:06 2018 daemon.notice odhcpd[903]: Got DHCPv6 request
Sat Sep  1 00:21:06 2018 daemon.warn odhcpd[903]: DHCPV6 SOLICIT IA_NA from 000100011e81b8d3fc3fdb484ffb on br-lan: ok fdc0:2487:f87c::35d/128
Sat Sep  1 00:21:06 2018 daemon.info dnsmasq[807]: read /etc/hosts - 4 addresses
Sat Sep  1 00:21:06 2018 daemon.info dnsmasq[807]: read /tmp/hosts/odhcpd - 0 addresses
Sat Sep  1 00:21:06 2018 daemon.info dnsmasq[807]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Sat Sep  1 00:21:07 2018 daemon.notice odhcpd[903]: Got DHCPv6 request
Sat Sep  1 00:21:07 2018 daemon.warn odhcpd[903]: DHCPV6 SOLICIT IA_NA from 000100011e81b8d3fc3fdb484ffb on br-lan: ok fdc0:2487:f87c::35d/128
Sat Sep  1 00:21:09 2018 daemon.notice odhcpd[903]: Got DHCPv6 request
Sat Sep  1 00:21:09 2018 daemon.warn odhcpd[903]: DHCPV6 SOLICIT IA_NA from 000100011e81b8d3fc3fdb484ffb on br-lan: ok fdc0:2487:f87c::35d/128
Sat Sep  1 00:21:21 2018 daemon.notice odhcpd[903]: Got DHCPv6 request
Sat Sep  1 00:21:21 2018 daemon.warn odhcpd[903]: DHCPV6 SOLICIT IA_NA from 000100011e81b8d3fc3fdb484ffb on br-lan: ok fdc0:2487:f87c::35d/128
Sat Sep  1 00:21:31 2018 daemon.notice odhcpd[903]: Got DHCPv6 request
Sat Sep  1 00:21:31 2018 daemon.warn odhcpd[903]: DHCPV6 REQUEST IA_NA from 000100011e81b8d3fc3fdb484ffb on br-lan: ok fdc0:2487:f87c::35d/128
Sat Sep  1 00:21:31 2018 daemon.info dnsmasq[807]: read /etc/hosts - 4 addresses
Sat Sep  1 00:21:31 2018 daemon.info dnsmasq[807]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  1 00:21:31 2018 daemon.info dnsmasq[807]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Sat Sep  1 00:22:40 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:22:40 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: disassociated
Sat Sep  1 00:22:41 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sat Sep  1 00:32:53 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: authenticated
Sat Sep  1 00:32:53 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: associated (aid 2)
Sat Sep  1 00:32:53 2018 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:32:53 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz WPA: pairwise key handshake completed (RSN)
Sat Sep  1 00:33:05 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 30:52:cb:xx:yy:zz
Sat Sep  1 00:33:05 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: disassociated
Sat Sep  1 00:33:06 2018 daemon.info hostapd: wlan0: STA 30:52:cb:xx:yy:zz IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sat Sep  1 00:56:24 2018 authpriv.info dropbear[16230]: Child connection from 10.11.11.150:51116
Sat Sep  1 00:56:33 2018 authpriv.notice dropbear[16230]: Password auth succeeded for 'root' from 10.11.11.150:51116

All help will be greatly appreciated.
Please let me know if I need to raise the level of debugging on the routers in order to grab the issue. Also, please let me know how to raise such debugging level on the routers because I don't know how to do such a thing.
Thanks in advance.
Cheers

TBH, identifying and fixing your problem in LEDE/OpenWRT is easier said than done particularly if no one else is reporting same symptoms.

I've seen compatibility issues with Intel centrino wifi cards connecting to 2.4 GHz atheros based wifi. See this post.
https://forum.openwrt.org/t/slower-speed-after-update-from-15-05-1-to-17-01-4-with-intel-intel-centrino-ultimate-n-6300/12805/17

One suggestion is try an inexpensive USB wifi adapter to see if it performs any better if your broadcom card is incompatible. To best of my knowledge, most of the cheap wifi dongles use Realtek or Mediatek/RAlink chipsets. Finding one with Qualcomm/atheros could be difficult.

Another workaround is not to use wifi and to try a pair of powerline adapters. Plug one into the laptop's ethernet socket, and other into one of the routers.

Have you also considered your wifi problems may be simply down to wifi congestion and interference from neighbours? 2.4 GHz is more susceptible to this issue than 5 GHz wifi.

Is that really all I can do? Work around the issue by using wifi dongles and stuff?
We're talking about a laptop PC that has been working at a customer's office 8h/day for a full year connected only through wifi with 0 issues. And yet it fails miserably here at home.
And there's nothing proving that this wouldn't happen with any other laptop computer because I simply don't have another PC to test. Right?

I'd be ok if you or someone else had looked at the logs and said: "hey, there's a bug" or "hey, your router is broken" or something similar.
But what you're saying is we can't tell what's going on by reading the logs. That's frustrating...

What if I told you that the customer where I used to work for the past year also has a TP-Link 1043ND (can't tell the hw revision) but it is running the official firmware by TP-Link? Zero issues in there...

I don't know. I'm not ranting, ok? I am just showing some frustration and the truth is I'm glad you've been replying to my messages because otherwise I would have been talking to myself. :disappointed:

So thanks a bunch, man. :+1:t3:
And please let me know if you have any other ideas on how to investigate this further, as long as it doesn't involve changing hardware that's been working fine elsewhere.
Cheers

PS:

Actually, I had a buddy come over to my house and explained him my issues and he was suspecting the same. But then he used Ekahaus and said that although there's some minor interference it should be pretty much ok for wifi to work just fine. FWIW he installs wifi for a living so I guess he might be right.

The log says

802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

something for you to investigate further

1 Like

Catching that straw:

802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

Does this help?
/etc/config/wireless → @ config wifi-iface → add option disassoc_low_ack '0'

1 Like

Turning off Power Saving mode under 'Power Management' tab for the wifi card in Windows Device Manager has been known to fix some issues.

1 Like

Thanks guys.
I have made the changes proposed by @tmomas and disabled PM as per @bill888 tip.
It has improved a bit and I can work for 2 or 3 hours and then all of a sudden it just happens a couple of times with the same issue (deauthenticated due to inactivity).
Which is not true. Although my work is not very network intense, I do need to carry out internet research every 5 to 10 minutes.
I'm puzzled...

The weird part here is that one of my customers has a router just like this one and while I keep the settings on the PC untouched, at his office my laptop can go for as long as 10 hours straight with no issues whereas at home I can't work for more than, say, 2 hours straight without this issue.
His router is surely on stock FW and it might not be the exact same HW version as mine, but I have no way of telling that.

But I've turned Power Management off on my laptop's wifi adapter and still have issues.
Some days it goes better than others but the issue is still here.