Loose my access to the device

I have a few devices with OpenWrt. When tried to switch one of them from static IP address to DHCP, I changed the Protocol from Static address to DHCP client and then clicked Save & Apply without clicking on Switch protocol. Since then I can not access the device.

The device:
Model 8devices Carambola2 board
Firmware Version OpenWrt Barrier Breaker r41554 / LuCI rfid_carambola2 Branch (git-15.151.52871-a835fc0)
Kernel Version 3.10.44

Could you please, advise me on how to restore access to this device?

1 Like

This OpenWrt release is ancient, unsupported, and has known security issues. You should update your device as soon as possible to a current OpenWrt release.


Thank you for your reply, @vgaetera ! Unfortunately, the OpenWrt is flashed on the Carambola 2 board and I do not have any buttons to press. Tried the option with the listening for a message with tcpdump but did not get any.

1 Like

They were often sold attached to this carrier PC board which has two Ethernet transformers and RJ-45 connectors, a reset button and a USB converter for the serial port.

If you only have the Carambola module itself on a different board, you'll need to wire up buttons or a serial port.


The mini usb cable that provides power to the Carambola2 development board is also serial port @115200 8N1.
If you don't have the development board the pins are on page 2. 45-43 UART+GND, 33 reset


@mk24 and @trendy , thank you very much for your help! I think you are pointing me in the right direction. Maybe I have to share this in the beginning. Please, see the attached picture, this is the board I have. From the producer, I have information that the OpenWrt is flashed using the PS2 port which looks a bit suspicious to me, but it may be true. Maybe you can tell better?

This is some custom board, so I would work on the carambola2 chip directly.

@trendy, could you please tell me what is the idea - to connect a serial port to these 3 pins or maybe connect a vutton to reset the biard?

Thank you very much for your time and help!

If you can find where these pins are connected to on the board, it might save you the soldering.
Otherwise you can start by connecting the reset pin with a ground.
If that won't work, go for the serial console. A usb to ttl adapter will do the job.

@trendy, I tried with the reset pin connected to the GND but nothing happened. Is there an exact moment when I have to "click" it? On my attempt, I just kept it "pressed" while powering the board and wait some time. Then connected the board to the computer with LAN cable and checked the DHCP server. No request there.

I haven't tested it myself, but I would start by keeping it pressed for 15" while the device is running, looking at the leds, and expect that the device would reboot on a clean config.

@trendy, tried this and I can tell that the board is restarting. There is a led connected to the larger bord below the carambola which goes ON when I connect GND and reset and stays on while they are connected. Than goes off. Also In the moment when I connect GND and Reset I have a message in the computers syslog (where the LAN is conncted) - kernel: [15682.397869] r8169 0000:02:00.0 enp2s0: Link is Down. and later kernel: [15683.981244] r8169 0000:02:00.0 enp2s0: Link is Up - 100Mbps/Full - flow control rx/tx so it seems that this action is making something with the board but still no DHCP requests. Can you where I'm wrong?

Also I chacked one more thing. Connected USB cable to the USB port on the board (see the image I attached yesterday for reference) and on the other end of the cable I measured that 3 of the wires are connected to GND, RX and TX on the Carambola 2. If I solder these 3 wires to a RS232 and plug it in an old computer I theoretically could be able to connect to the board. But than what? How to restore my access?

Thank you again for your help.

"Reset" will be one of the GPIO pins not the "HW_RESET" which only soft-restarts the chip like cutting the power does. Possibly the schematic of the dev board tells which one. The dev board has two buttons near the bottom.

The serial will be 3.3 volt level do not connect it to a DB9 port, you need a "TTL" or 3.3 volt adapter. If OpenWrt boots at all, you should have a root shell on the serial, where you can edit the config files to fix the misconfiguration. If OpenWrt doesn't boot you can use bootloader commands over serial to download and flash a new installation.

@mk24, thank you for your reply. Did you saw the image I've posted? My dev board does not have buttons. In this wiki page near the bottom I can see another reset button is mentioned. Is this what I need?

This is the official devboard. The hw-reset button is the one connected to pin 33.
Your board is custom made, I doubt anyone else here has ever laid hands on it, so you'd better work directly on the pins of carambola2. Connect the ttl serial to the 43-45 pins 115200 8N1 and check from the console what the problem is.

Thank you @trendy. I'll try to find a TTL serial tomorrow. It's something I do not have laying around the house. I found these 3 in the nearby shop. Can you advise me which one is preferable? Thank you very much for your time and help! Cheers!

Choice of these is based mostly on the chip they use. If your PC is Windows avoid the PL2302 chip since many of those chips are counterfeit (or allegedly so) and the Prolific Windows driver refuses to work with them. I have several like the one in the middle with wires-- it has a PL2302 chip but works fine with Linux.

1 Like

Thank you @mk24! I'm using Linux. Will take the same. It's listed as: K2169 Converter USB to UART RS232 TTL PL2302HK CABLE 4PIN
The one witout the cables is: K2102 USB converter to RS232 TTL-PL2303HX

This is also an available option (UART TTL FT232RL 6PIN):