Loop between router and Dumb AP?

Hi,
after some time running router with openwrt and a stock asus router as a dumb ap, I moved on to two 1900acs where one is router and the other is dump ap (192.168.1.1 and .2).

Had a little trouble with both 5ghz wlans being enabled at the same time. Disabled 5ghz on router and it's now working fine from my dumb ap.

Router system log is being overloaded with

Tue May  4 19:07:57 2021 kern.warn kernel: [ 2820.185719] br-lan: received packet on lan1 with own address as source address (addr:60:38:e0:da:5a:be, vlan:0)

60:38:e0:da:5a:bF (read F) is router's 2.4ghz mac address. bE I don't know what is..

On the dumb ap I've bridged everything except switchport wan. I tried to bridge only eth0 and wireless network (both) but then I lost connection to the internet and my router. Dumb Ap is connected with network cable on lan port 1 I think back to my router.

Thanks!

This should work without issues...

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless

Router config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config device 'wan_wan_dev'
        option name 'wan'
        option macaddr ''

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option cell_density '0'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:da:5a:c0'
        option encryption 'psk2'
        option key ''
        option ssid ''
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option cell_density '0'
     

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:da:5a:bf'
        option encryption 'psk2'
        option key ''
        option ssid ''

AP network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdaa:a4cb:8348::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        list dns '192.168.1.1'
        option gateway '192.168.1.1'
        option delegate '0'
        option ifname 'eth0 lan1 lan2 lan3 lan4'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config device 'wan_wan_dev'
        option name 'wan'
        option macaddr ''

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option cell_density '0'
        option channel '100'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '58:ef:68:0c:eb:95'
        option ssid ''
        option encryption 'psk2'
        option key ''

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '58:ef:68:0c:eb:94'
        option encryption 'psk2'
        option ssid ''
        option key ''

This question has been asked a lot, did you read the other topics for similarities?

2 Likes

Are you sure you are not reusing a MAC address from some other device in your network?

  1. You can run ip addr show on both devices to see which Mac addresses are used by which interfaces. This should point you to the interface that is listed in the log.
  2. If you disconnect the AP, there are no new messages in your routers system.log. Right ? What happens if you stop wifi on the AP ?
  3. With ip neigh show you can see the arp cache of the devices, showing ip and mac addresses and the used interface. You can run that on both devices, compare with what luci tells you about wifi clients and make sure that every device shows up where it should do that.
1 Like

Thanks for your replies,
I tried a bit of googling but maybe to specific.
The issue with log messages disappeared, it could be because of two things I did;

  1. restart both router and AP
  2. remove eth0 from bridge on router

Everything seems to be working fine now, I'll try to bridge eth0 again later, as I understand this is the switch itself and not the virtual ports. All ports are still bridged if I understand correctly.

When videocalling with my iphone I might spot a little problem with my 5ghz setup. I've not enabled anything fancy but sqm (90% of limit, 300/300 fiber) and 5ghz on my AP is on a different channel from my router. The video stream got blurry and my recipient couldn't see my video clear.
I believe we have dual coverage on 5 ghz wireless from both AP and Router in 50% of the house, could that lead to problems?

On my AP system log this is repeating a lot:

Wed May  5 10:10:22 2021 kern.debug kernel: [58526.263670] ieee80211 phy0: Mac80211 start BA c8:21:58:xxxxxx

First google search led me to this;

last post saying;

brainslayer:
ignore it. thats debug output shit of the mwlwifi driver. it just says that a ampdu block ack session has been started / stopped. block ack is a form of packet aggregation which increases performance. so if you see that message all is running as expected. i dont know why openwrt enabled debug output for that driver. its useless and confusing, but no error. just a information whats currently going on

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.