Looking for info and possibility of (future) support of TP-Link Omada er605 Router

ubiinfo -a

If you check post 58 ubinfo -a definitely has only one i. Either way, I tried it anyway with the same result.

root@ER605:~# ubiinfo -a
-ash: ubiinfo: not found

Ubinfo, in fact all of mtd-utils doesn't appear to be included. (At least not in any of the usual locations or elsewhere in PATH)
/sbin/mtd is the closest I've been able to find.

Base OS says it's Barrier Breaker, so https://openwrt.org/releases/14.07/notes-14.07

(Assuming UBI was something that was in use back then), I could try copying a period/release appropriate version of ubinfo (all the mtd-utils?) over and see if it runs.

(looks like I'd start at https://github.com/openwrt/openwrt/tree/master/tools/mtd-utils)

2 Likes

Honestly, I was wondering if it was enabled as well? Post 41 does show that the V2 was also on Barrier Breaker but on my V1.6 when I hunt around for /dev/ubi0 (what post 52 asks to dump) using WinSCP it does not appear to exist. (Honestly, I really don't know what I'm looking for so maybe that's referring to something else or /dev/ubi0 can't be viewed this way)

1 Like

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=62dbcb8305d7d28393e1d7157680f9c6dbfbed63

Good news!!! One step foward for V2.

1 Like

does this mean we can flash the sysupgrade file from the TP-Link GUI ?

I'm not sure, maybe @kolya can tell us something about :sweat_smile:

In my case I'll wait to be fully ported/added before flashing it.

No,

Until someone can reverse engineer the TP-Link firmware file format (layout and magic numbers etc) the only way to flash this is thru UART booting into the initramfs and flashing thru that.

1 Like

No, as Darbness is saying: at this time OpenWRT cannot build firmware file 'compatible' with proprietary FW format. So at best factory FW will not accept that file. At worst it will 'flash the wrong thing'.

2 Likes