Looking for info and possibility of (future) support of TP-Link Omada er605 Router

USB support is already present in OpenWRT. You may have to install packages to enable USB support for the device you are trying to use.

Works great. Thank you so much.

1 Like

Thank you for the script and the clear instructions for flashing.
Was up and running in OpenWRT 23.05 in less than 5 minutes.

Just to be clear, the procedure to return to stock if needed is:
ubiformat /dev/mtd3 -f /tmp/mtd3_firmware.backup
and then follow the tp-link instructions for full recovery
https://www.tp-link.com/in/support/faq/3062/ ?

Thank you again.

No problem. :slight_smile:

Since the mtd3 image is too large to fit in the RAM of the ER605, you will need to pipe the image over ssh or from a http server directly to ubiformat instead of saving it into /tmp first. So the command would look something like this: wget -O- http://[url to mtd3.img on a local http server] | ubiformat /dev/mtd3 -S [size of the image in bytes] -y -f -

I'm interested in the ER605, so I bought a v2 to play with. I also have a couple of ER-Xs, which I figured would be essentially the same device +-PoE and the USB port. Reading through the two device trees, however, there's at least one significant difference.
On the ER-X, all five switch ports go to RJ45 connectors. On the ER605, however, it looks like only 4 switch ports (1-4) go to connectors, while the WAN connector is plumbed up to a dedicated port on the SoC.
I wonder what that means in practice. I know that ER-X has two CPU ports, so it can handle 2Gbps total HW offloaded routing between any of the switch ports. Also all five ports should be able to do bridge offloading.
If I understand the architecture correctly, the ER605, in contrast can "only" do 1Gbps routing between the 4 exposed switch ports, or 2Gbps between WAN and switch? Also it presumably won't do bridge offloading between WAN and the switch?
I guess this is the same situation as the ER-X-SFP between the SFP port and the rest?

In any case, I have decent photos of the PCB, so I can at least fill in the ToH?

Here's the top of the PCB. It looks like this has been cost-optimized to the max - I figure the shape of the PCB will yield an extra 10% per panel. I wonder if the 8-pin footprint next to the serial port might be JTAG?

Here's the bottom of the PCB. Note how there's a footprint for what's likely an RJ45 console port on the far right of the PCB. I don't see an alternate location for the reset switch, though.

1 Like

No, those belong to alternative/ unpopulated headers for flash chips; many vendors prepare their PCBs so they can swap that one out for the cheapest alternative on the spot market without further changes (so you will see soic-8 and soic-16 headers on many devices).

2 Likes

I added a hardware info page and an initial ToH device page: https://openwrt.org/toh/tp-link/er605_v2. It's mostly a ToDo/FIXME for now, I'll noodle at it in spare moments. Please let me know if you see anything wrong.

1 Like

This is just sad, I just wanted to do some tweaks to old OpenWRT they have there but now I can't, I reported this to their forums I wonder what they will reply

I dont wanna go full OpenWRT because I also want to manage everything in omada.. just wanted to try to install controld

Hi, I just installed 23.05.02 on a ER605v2. Now trying to use it... internet speed is just awfully slow. My regular router (Netgear WAX206, also on 23.05.02) does a steady 700+ Mbit up/down; the ER605 handles less than half of this, a lousy 280Mbit up/down.

Is that expected? Are there any offloading tricks that aren't present on the ER605 yet? My ISP has PPPoE (=overhead) and I'm getting a full IPv6/48 (no extra NAT overhead).

I also tried sending only IPv4 NAT traffic on my local network through the ER605 (Hooked it up as if my local net was the ISP, simple 1 on 1 NAT, cat /dev/zero|nc -l 12345 on the local network that served as fake "WAN", and nc ip.address 12345 > /dev/null on the NAT'ed lan-side), that did a steady 800mbit. So what's happening?

1 Like

Hi,

My ER605 V2 in PPPoE can handle more than 300 Mbit up/down (that's what I have contracted to my ISP):

   Speedtest by Ookla

      Server: xxxxxxxxxxxxxxxxxxxxxxxxxxxx
         ISP: xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Idle Latency:    10.26 ms   (jitter: 0.15ms, low: 10.21ms, high: 10.51ms)
    Download:   311.84 Mbps (data used: 148.9 MB)
                 16.33 ms   (jitter: 6.89ms, low: 8.62ms, high: 241.59ms)
      Upload:   310.66 Mbps (data used: 240.3 MB)
                 33.32 ms   (jitter: 1.56ms, low: 7.10ms, high: 36.89ms)
 Packet Loss:     0.0%

I have software and hardware offloading enabled:

root@ER605:/etc/config# cat firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'
        option drop_invalid '1'

Thanks,

2 Likes

Thanks a bunch! That is a 100% difference - speeds are WAY up - 920Mbit / 850Mbit.

Shouldn't this be on by default? I'll mention the setting on the HW page.

1 Like

Nice to help you!!!!

IMO yes, especially in MT7621 devices where hardware NAT is fully compatible with OpenWRT.

Just in case someone else has the need to restore the ER605 v2 back to stock firmware here are the steps I followed (many thanks to chill1Penguin for his insight ):

  • Solder UART Console Port
  • On the uboot-console "run enphy" (for some reason I could not ping the device or use tftpboot even with this)
  • From uboot console boot a openwrt initramfs image (used xmodem protocol and the program Teraterm for this)
  • When on the openwrt console type "ubidetatch -p /dev/mtd3"
  • Then "wget -O- http://[url to mtd3.img on a local http server] | ubiformat /dev/mtd3 -S [size of the image in bytes] -y -f - "
  • When finished reboot the device and it should boot to the point you had taken the image.
  • For completion reasons I also did the failsafe recovery that is described https://www.tp-link.com/in/support/faq/3062/

I bricked mine for deleting some luci components (my bad). How can i recover openwrt? Not planning to return to OEM firmware, but dhcp and ssh are dead. If you press reset, you still get the emergency firmware patch but i dont want to return to the OEM firmware, though i tried reloading it but no gain.

Any leads please? Thank you
IMG_6015

https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

For anyone interested, ER605 v2 working fine with Kernel 6.1:

root@ER605:~# dmesg
[    0.000000] Linux version 6.1.78 (klingon@Empire) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 12.3.0 r25004-b463737826) 12.3.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Wed Feb 21 01:34:32 2024
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is TP-Link ER605 v2
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
root@ER605:~# uname -a
Linux ER605 6.1.78 #0 SMP Wed Feb 21 01:34:32 2024 mips GNU/Linux
root@ER605:~#

usually those stuff are not really deleted by any means, its more like that the overlayfs trick it that you deleted the file but in reality its still there. Doing a reset usually fixes this issue, just press the reset button after 5minutes you turned it on.

Weird that you have had to build that yourself, is the 6.1 kernel not in current snapshots for the er605?

anyone else have an er605 v1 that is still looking forward to Openwrt support?

No, you have to build it yourself for kernel 6.1 (is test mode kernel options), snapshots are in 5.15