Looking for info and possibility of (future) support of TP-Link Omada er605 Router

Does your solution mentioned in github require us to solder the pin or will it work without having to open up ER605 V2 (currently on beta 2.1.4) ?

It should work without having to open the device up at all. If something does go wrong due to a bug or something like that, then opening up the device and soldering will be necessary for a recovery.

I have significantly simplified the install process by removing the need to generate the recovery image. (I'm not sure why I didn't think of this way earlier. :man_facepalming: ) The new method of installation should prevent the problem of booting back into the factory firmware after flashing the initramfs image. See https://github.com/chill1Penguin/er605v2_openwrt_install if you would like to attempt the install. Feedback is appreciated!

2 Likes

If I acquired a v1 device and confirmed that the install worked for me, would you be willing to help me test the install on your v1 device?

I followed the steps mentioned in @chill1Penguin github page and everything went smoothly. Thank you for all your help: https://github.com/chill1Penguin/er605v2_openwrt_install

Yes i have both v1 and v2 to hand.

@chill1Penguin is there any way to revert from OpenWRT to Stock firmware? (I have no intention to get back into stock firmware, but will be great to know it while my device is still in warranty).

Yes, there is. You can use your backup of the mtd3 (firmware) partition to restore it using ubiformat. There also may be a way if you didn’t do a backup, but I haven’t tested that way yet.

2 Likes

I too have a v1, and I am also interested in / willing to test this firmware.

users of this specific item, can you share your usage?

In a specific setup this device was replaced due to the fact that on its own with stock firmware it cannot prevent VLANS from communicating with each other. I was unable to isolate the VLANS.
Does anyone of you experience same with this item? can you share please.

And what about openwrt firmware on it?

I have 2 isolated VLAN's working like a charm (1 for IOTs devices / 1 for LAN).

I run a very basic config, Fiber Internet (PPPoE) + 2 VLANS + DDNS + OpenVPN Server
The device is working much much.... better than stock firmware, till now 0 issues!!!

root@ER605:~# ubus call system board
{
        "kernel": "5.15.126",
        "hostname": "ER605",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link ER605 v2",
        "board_name": "tplink,er605-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r23727-e6f8b69918",
                "target": "ramips/mt7621",
                "description": "OpenWrt SNAPSHOT r23727-e6f8b69918"
        }
}
root@ER605:~# uptime
 08:39:10 up 8 days, 51 min,  load average: 0.00, 0.00, 0.00
root@ER605:~# free
              total        used        free      shared  buff/cache   available
Mem:         249728       46572      165648        1204       37508      159228
Swap:             0           0           0
root@ER605:~#

I hope it helps @ZOzo

1 Like

thanks for your feedback, and how was its behaviour with stock firmware?

Not very good (it wasn't a disaster).

I had problems with OpenVPN (only accepting 128-CBC encryption, not 256-AES).
No logs/info about nothing (OpenVPN, Wireguard....).
Sometimes GUI was unresponsive/slow
The strange sensation stock firmware was doing something behind making the router going slow.
I had to put acl's to block traffic between VLAN's (by default traffic is allowed - IMO should be forbbiden).
.....and many other little things make me change to OpenWRT.....

I won't come back to stock firmware, that's for sure.

your response gave me a courage to get this little device off the cupboard, just upgrade it to RC3 still no working functioning VLAN for me unfortunately. really no luck

also my MAC address change after each restart

Hostname OpenWrt
Model TP-Link ER605 v2
Architecture MediaTek MT7621 ver:1 eco:3
Target Platform ramips/mt7621
Firmware Version OpenWrt 23.05.0-rc3 r23389-5deed175a5 / LuCI openwrt-23.05 branch git-23.219.80063-bece581
Kernel Version 5.15.127
Local Time 2023-08-19 14:59:54
Uptime 0h 13m 3s
Load Average 0.07, 0.09, 0.04
1 Like

What is not working?

In LAN or WAN?
I'll check my device if it happens too.

Checked: you are right @ZOzo changes MAC of dsa device. The rest of devices (eth0, eth1... remains).

vlans not working. can be configured on the er605 but connected devices can never get on into the vlan.

MAC changes after every reboots all of them

Precision: the VLAN on the ER605 received packets (RX) but does not transmit (TX) so no services out from the ER605 thus no DHCP services out!

My VLAN's + DHCP Server's are working.
Maybe is something related to firewall config?

hopefully the whole developer team come with a solution by also have the mac address fixed and same as what is printed on sticker with serial number :+1: