Looking for bootloader of TP-LINK WR1043ND V4 (solved)

Looking for bootloader or complete image of TP-LINK WR1043ND V4

I tried to install openwrt/lede on TP-LINK WR1043ND V4 but somehow managed to brick it completely. Now I have no tftp or serial access.

I am looking for bootloader or complete image which I can flash using flashrom utility. Alternatively if I do one of the following will I be able generate working image myself? Please correct me if I am wrong.

  1. Create an image using oem firmware

Download oem firmware from TP-Link (wr1043ndv4_eu-up-ver3-16-9-P1-20160607-rel58297.bin)

Because oem firmware is 5mb and flash chip is 16mb both has to match for it to work with flashrom utility. So create 16mb file filled with zeros

dd if=/dev/zero of=oem.bin bs=1024 count=16384

Merge oem firmware into oem.bin

dd if=wr1043ndv4_eu-up-ver3-16-9-P1-20160607-rel58297.bin of=oem.bin conv=notrunk

will it work?

  1. Create an image using bootloader of another router

Copy bootloader from another identical router

dd if=/dev/mtd0 of=/tmp/boot.backup

create 16mb file filled with zeros

dd if=/dev/zero of=custom.bin bs=1024 count=16384

then merge boot.backup into bootloaderonly.bin

dd if=boot.backup of=bootloaderonly.bin conv=notrunk

will it work?

broken image is https://datacenterengineers.com/index.php/s/z9kCVRNk26rlZYD
bootloader https://datacenterengineers.com/index.php/s/moXGVwcjfj3k25B

Make sure to try really hard to recover at least the ART partition, as that one is device specific and can't be recovered once you've lost it.

I still have broken image which contains corrupted/failed install of openwrt/lede. ART partition might be in it I am not sure. I think I'll loose wifi capability if ART partition is lost. As long as WAN and LAN works that's all I want.

Thank you for your prompt response.

The bootloader is included in most TP-Link OEM firmwares, you can just cut it out of those - and assemble your firmware from that (u-boot, u-boot-env, kernel/ rootfs, art).

Successfully repaired corrupt image of TP-LINK WR1043ND V4 by following steps

  1. Setup Beaglebone Black as spi programmer using instruction provided in https://libreboot.org/docs/install/bbb_setup.html. Instead of desoldering the flash chip from PCB. I took out entire PCB from casing and soldered thin wires directly to flash chip.

  2. Extracted corrupt image from flash chip using flashrom 0.9.9 utility

    sudo flashrom -p linux_spi:dev=/dev/spidev1.0,spispeed=512 -r dump.bin

  3. Downloaded lede firmware lede-17.01.4-ar71xx-generic-tl-wr1043nd-v4-squashfs-sysupgrade.bin

  4. Repaired corrupt image by merging lede firmware into dump.bin

sudo dd if=lede-17.01.4-ar71xx-generic-tl-wr1043nd-v4-squashfs-sysupgrade.bin of=dump.bin bs=1 seek=$((0x20000)) conv=notrunc

  1. Wrote modified dump.bin back into flash chip

sudo flashrom -p linux_spi:dev=/dev/spidev1.0,spispeed=512 -w dump.bin

  1. Desoldered all wires from flash chip and inserted PCB into the router casing. It is now working beautifully.