Long wait for web interface response

Yesterday, I updated the firmware of my router (TP-Link TL-WR840N v4) to version 19.07.0 and ran into the almost ubiquitous “Loading view…”. I find him almost wherever I go, but the waiting time is different. Somewhere it lasts 1-3 seconds, and somewhere up to 5-10 seconds. This is very annoying.

Tested through Firefox and Chromium. There is no time difference. Anyone have any ideas for reducing response time?

I changed these settings (option http_keepalive 0 and option tcp_keepalive 0) in /etc/config/uhttpd, but nothing changed.

Hi Tom,
don't have a conclusion for you but I have the same issue on TP-Link Archer C7 v2.
Just want to let you know, you're not alone :slight_smile:

Not sure whether meantime resolved but another user also reported

Is this via HTTPS ?

Hi riodoro. I am glad that I am not alone in this matter, but I am not glad that we are experiencing this problem)

jow, Yes worth the luci-ssl package

Can you check whether non-HTTPS works fast? You might need to disable/comment out the listen_https and redirect_https directives in /etc/config/uhttpd.

1 Like

Commented out the specified lines and now the time has been reduced to about 3 seconds.

Okay, so you still wait a long time for things to happen?

I wait about three seconds, it is certainly faster than it was before, but I would like to improve it even more, if possible. And on https.

The HTTPS slowness is hard to solve. Browsers, Chrome in particular, proactively open many parallel SSL connections which strains the relatively slow CPU on your device.

As for improving the general performance, please try the following:

  • install uhttpd-mod-ubus using opkg
  • restart uhttpd
  • logout in LuCI and close the browser tab to clear the session storage
  • reopen LuCI in a new browser tab and see if performance improved
1 Like

Now everything has become clear. Performance has improved, the interface opens almost immediately after clicking. I think this is enough for me. Thanks for the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.