Locked out of device

Hi all. I have a NanoPi R6S running a snapshot release of OWRT. It has been working just fine until now. I went into the device to change the DHCP address from to The device has locked me out. I cannot open Luci on either 1.1 or 2.1 and I can no longer SSH into the device. I'm not sure exactly what I've done wrong. I have disconnected from the modem and the problem persists. It appears the Reset button on the side doesn't do anything - likely not supported in the firmware. If I plug my computer into the device it gets an IP address but the router is not accessible. If I plug the WAN port into a different router, it receives an IP address from that router, but alas the router itself is no longer pingable nor can I SSH in or access the device. I'm assuming this is a re-flash using an SD card situation, but I'm wondering if there's any other options I could try before hand?

The snapshot that this device runs is not from the official OpenWrt project since this device isn't supported here. The NanoPi people have made significant modifications to OpenWrt, the details of which are not known to the community here. As a result this becomes unsupportable by the official OpenWrt project.

You can try the failsafe method to regain access and fix the problem.

But if that doesn't work (and for all of your other questions with this device) you need to use the NanoPi support channels.

1 Like

Thank you, I’ll give failsafe mode a go and hopefully that allows me to fix the issue.

If you router is now, make sure that your PC has an IP from the 192.168.2.x subnet for normal SSH.

(Note that in failsafe mode the router reverts back to default and again you need to verify that PC's address is right)

1 Like

The computer receives a DHCP address from the router, but i cannot ping the router itself ( and I cannot access luci from that address either. I can see the router in my ip scanner software, but it states it is not pingable and doesn’t have a website. This appears to be due to the Wireguard interface I set up. I must’ve entered a conflicting IP address into it that ruined the connection. I managed to connect to it through wireguard and I deleted the interface thinking that would resolve the issue. I still cannot get in and the only work around I found I deleted. I need to figure out how to reset it or reflash the firmware. I initially installed OWRT through the friendlywrt interface that the box shipped with. The failsafe route for supported OWRT images does not appear to work on this snapshot version.

Firmware from the official project has working failsafe mode in both release and snapshot versions. It would be strange if the version you're using was any different, but maybe someone introduced a bug or something. You'll probably need to reach out to friendlywrt or whoever maintains the firmware you installed for additional help.

1 Like

Sounds strange. Failsafe is a default feature and can be disabled only via explicit disabling in config. Certainly not disabled in a normal buildbot snapshot image.

But triggering the failsafe can be difficult as it requires a button push inside a 2-second window. (Not a "button held down", but "button pushed" action).

(For that reason I have increased the timeout for 5 seconds in my own builds and have tried to prolong the time in the official OpenWrt via PR https://github.com/openwrt/openwrt/pull/11852 )

You should try repeatedly pushing a button during the boot to catch the correct time window.

Try to reach it via it's ipv6 link local address. Figure out the address with

ping ff02::2%<interface>

Where <interface> is the name of the interface on your computer, e.g. enp0s25. Then try to ssh the address that is answering (again with the %<interface>).

1 Like

Thank you for all the suggestions!

I am unable to utilize failsafe mode. It just doesn't catch, even when repeatedly pressing the reset button during boot up. My guess is this button isn't seen by the firmware. Perhaps a keyboard plugged into the device? Would that be considered a button push?

I have attempted to ping ff02::2%<interface and it just says host unreachable.

The device is not bricked as it still boots. I've just done something to completely disable root access. There is a Mask button on the device and some third party software to reflash the device over a USB connection. I've ordered an appropriate USB cable and will try re-flashing that way. Unfortunately the support software is primarily in Chinese, so this will be a little journey.

This issue arose from creating a wireguard interface which in turn I must have entered a conflicting 'allowed IP address' - be careful with your configurations, guys! Thankfully I documented most of the config changes I made up until the WG setup, so it shouldn't be too hard to reconfig what I had before once I've re-flashed this unit.

Alright, I managed to reset this thing. Including the info below for anyone who might stumble on this with the same issue. The device skipped booting from SD straight to EMMC every time, so trying to flash from an SD card did not work, nor did pressing the mask button to force it. I suppose this only works with FriendlyWRT official images.

I took the unit apart and saw it has a Serial/UART connectors on the board. I soldered a small makeshift header on it and ran Putty on my Windows bootcamp using the serial configuration outlined on the FriendlyElec wiki. I plugged my serial USB device in and I was able to monitor the boot up process. Interestingly enough, it did offer a failsafe mode, but way after I assumed it would and it was not indicated by any flashing LED lights. Hitting 'f' and enter rapidly when it appeared on the serial console got me into failsafe mode. I was unable to determine what I had done that locked me out, so I ran the 'firstboot' and 'reboot' commands to reset the device. I've regained access and have reconfigured the router.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.