Local Whatsapp calls (within router) not working


Since I installed openwrt 19.07 on my router Archer C20, Whatsapp voice calls stopped working (drop instantly) when performed between Two phones while both of them are on internet from the same router network (i.e between my phone and my wife's phone when we are connected to the same openwrt router).

1- it's not a wifi problem, same problem occures when we are connected to the wifi extender (lan connected to the main openwrt router).

2- Whatsapp calls work well when only one phone is connected to the router but the other phone is on another source of internet (on mobile data for example or a friend in another city).

Any fix?

Thanks in advance

Try downloading UPnP to your router, set it up and give it a try.

Still not working

did you turn it on and set it up? If yes, send a screenshot.

I can call people outside my house while I'm connected to my openwrt router. So I don't think the problem caused by closed ports.

The problem only occures between two phones when they are both connected to my openwrt router.

Ah, I thought you had a problem calling someone by whatsapp outside the router. Interestingly, I've never even tried that. Today I will try it and write the result.

Ummm does this work locally on any router?

I think you're asking whether WhatsApp voice calls were working well on the stock firmware when both phones are connected to the same router ?
The answer is Yes

1 Like

Please try it and report back

If you are using Apple devices with iOS 14, try to enable the Local Network permission.



Not working
The thing is that, inside home WhatsApp calls were working fine with the stock tp-link firmware. Never changed anything on the phones, what I've done is just installing openwrt on the router.

Can you guys please try to WhatsApp call someone connected to the same openwrt router you're connected to, and report back if you can hear each other ?

There is a switch under Network/Wireless/Interface Configuration/Advanced Settings called
Isolate Clients
Is it checked?


No it's not ticked.
It's not a wifi problem, I'm sure about that as I said before.

And btw, I checked whatsapp calls on three phones, one old android tablet, one P30 Pro, and one Iphone xr (all connected to the openwrt router)

The problem occures only between the P30 pro and the Iphone xr (call drops instantly).

The problem didn't occur between iphone and tablet, and between p30 pro and tablet.

  • Then how is this OpenWrt related?
  • And more importantly...how would we test this if your issue is between 2 specific model phones?

(I thought it may be firewall...until your last post.)


Is the problem symmetric ? Does it occur in the same way when the iphone xr calls P30, as it occurs the other way round ? Does it also affect video calls ?

If you want to spend the effort and dig in deeper, you might use a sniffing tool to see what is going on and compare the not working case with a working case. I have never done that, but

describes what to do.


Blaming the router, you ignored my previous post, but most likely the issue is caused by a new feature in iOS 14.

Here is the thread.

Of course I could be wrong if you use an earlier iOS version.


oh man I don't know what to say, may be because my wife's iPhone was able to call my P30 Pro perfectly on the stock router firmware I didn't think I have to change anything on it, and I was totally mistaken for not listening to you, sorry.

Problem solved guys, I just had to enable local network on the iPhone, thanks to all of you especially to pavelgl.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.