Local dns resolving not working through WG tunnel

I changed the nesmask to /24 on both client and and server.

I toggled the two options as described in the links. There has been no change in behavior.


Note that the second link is about specifying the VPN server's IP as a resolver for the client.

Correct, I used DNS) not the google DNS shown.

Is that DNS server responsible for the local domain zone which you want to resolve?

Yes? Again my apologies but I am answering based on behavior of the network, not from a foundational understanding. All my other WG clients and local clients are using this DNS server. The router (WG server) is pointing to this ip address for all DNS resolving. Is there something else that needs to be set to make it "responsible?

Tick the Log Queries in General Settings tab of DHCP and DNS, Save and Apply.
Post again the same configurations to verify that the changes have been applied properly.
Run a logread -f -e dnsmasq and try again to resolve the address. You should see the query and the answer logged. If you don't see it, it means that the client is using a different nameserver. Try to force it with nslookup rout.int

1 Like