List of neigbours empty when using batman-adv

I had mesh11sd working before but I want to create a guest wifi in the future. As a first step I wanted to move to batman-adv. I don't have any VLANs yet. I turned of all aps but one and my main router. I also uninstalled mesh11sd and installed kmod-batman-adv

iw dev mesh0 station dump lists the other device as authorized. But batctl n returns an empty list. I can't figure out why. Here is my config:

/etc/config/wireless:

config wifi-device 'radio0'
    option type 'mac80211'
    option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
    option band '2g'
    option country 'CH'
    option htmode 'HT20'
    option txpower '19'
    option channel '1'

config wifi-device 'radio1'
    option type 'mac80211'
    option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
    option band '5g'
    option country 'CH'
    option htmode 'VHT40'
    option txpower '19'
    option channel '36'

config wifi-iface 'mesh0'
    option ifname 'mesh0'
    option device 'radio0'
    option mode 'mesh'
    option mesh_fwding '0'
    option encryption 'sae'
    option mesh_id '<redacted>'
    option key '<redacted>'
    option network 'batmesh'

config wifi-iface 'wifi2'
    option ifname 'wifi2'
    option device 'radio0'
    option mode 'ap'
    option encryption 'psk2'
    option ssid '<redacted>'
    option key '<redacted>'
    option network 'lan'
    option ieee80211k '1'
    option wnm_sleep_mode '1'
    option bss_transition '1'
    option ieee80211r '1'
    option ft_psk_generate_local '0'
    option ft_over_ds '0'

config wifi-iface 'wifi5'
    option ifname 'wifi5'
    option device 'radio1'
    option mode 'ap'
    option encryption 'psk2'
    option ssid '<redacted>'
    option key '<redacted>'
    option network 'lan'
    option ieee80211k '1'
    option wnm_sleep_mode '1'
    option bss_transition '1'
    option ieee80211r '1'
    option ft_psk_generate_local '0'
    option ft_over_ds '0'

/etc/config/network

config globals 'globals'
    option packet_steering 'enabled'
    option ula_prefix 'fd36:01e4:eb19::/48'

config device 
    option name 'br-lan'
    option type 'bridge'
    option mtu '2304'
    list ports 'bat0'
    list ports 'lan1'
    list ports 'lan2'

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.10'
    option netmask '255.255.255.0'

config interface 'wan'
    option device 'wan'
    option proto 'dhcp'

config interface 'batmesh'
    option proto 'batadv_hardif'
    option master 'bat0'
    option mtu '2304'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms 1
	option ap_isolation 0
	option bonding 0
	option fragmentation 1
	#option gw_bandwidth '10000/2000'
	option gw_mode 'off'
	#option gw_sel_class 20
	option log_level 0
	option orig_interval 1000
	option bridge_loop_avoidance 1
	option distributed_arp_table 1
	option multicast_mode 1
	option network_coding 0
	option hop_penalty 30
	option isolation_mark '0x00000000/0x00000000'

What can I do to figure this out?

Nevermind. I wasted hours trying to figure this out. Turns out I only installed kmod-batman-adv on one of the two devices. :man_facepalming:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.