Linux Problem (I hope) with Meraki MR18

My enviroment: (With NO Internet Connection)
dhcp Server 192.168.2.3
meraki IP Adress 192.168.2.14
Windows PC running XAMPP 192.168.2.10
Firmware Meraki is 22-140575
None Linux knowlege
realy bad english kowlege


So i think i must use flashing Methode B
Steps like description
...
odm help
odm serial_num write Q2XX-XXXX-XXXV
odm serial_num read
...
Restart with Key s brings me to BusyBox
and the prompt is / # (What ever it means)
So far so good (I think) but now i dont konw how to go further

I could do some Commands but i don't know whats to do in Point 6 Flashing Methode A
There is a link to Github and there stands
... extract the files to the root of your local webserver. Once this is done and you have verified that the 4 images ...
In the actual Verion are two not four files.
openwrt-ar71xx-nand-mr18-initramfs-kernel.bin and
openwrt-ar71xx-nand-mr18-squashfs-sysupgrade.tar

So i copy this both Files to my local web server and tried
wget ht tp://192.168.2.10/openwrt-ar71xx-nand-mr18-initramfs.bin -O /storage/openwrt.bin
(IP Adress changed to my webServer is 192.268.2.10. I think that must or not?)

This command fails / was not known and the prompt changed to

First Question: What is with the four versus two Files that must be copied?
Second Question: What else must i do?

Regards Peter

The two files you need are at downloads.openwrt.org. Do not go to github. First you are going to flash the initramfs version, then boot it and use its sysupgrade feature to replace it with the full version, which is the tar file.

Make sure your web server works by trying to download the file on another computer on the LAN.

wget is a command to fetch something from a web server without having a browser. The -O option saves the page source to a file. Make sure the /storage directory exists and you can write files to it, for example:
touch /storage/testfile
creates an empty file -- then
ls -l /storage
should show at least one file: your testfile, with a length of 0.

... thanks a lot. I solved it. in my opinon there where to bugs in descrition.

  1. Under Windows i must use breckits ("") to enclose 192.168...
  2. First step (routing) works with every IP adress. But for install use i must (first) use IP adress 192.168.1.1
    and not like my Local Network ...2..
    However, it works (But have the files from Git, cause i did it bevore reading)

Should i make a update?

Regards
Peter

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.