Linux newbie requiring assistance from gigachads

Alright so here's the situation fellas:
I went and bought a Xiaomi AIoT AX3600 and followed the instructions (which required lots of googling) all the way down to step .8 " SSH
Secure Shell into OpenWrt from one of the LAN ports ".
I've spent a good few hours trying every ip address including ipv6 that was listed on ifconfig -a and every single one was either unknown or refusing connections. I tried unplugging the ethernet cable but addresses remain in ifconfig -a. Even tried without internet plugged into the WAN port on the router.

TLDR: How do you ssh from Linux Mint over ethernet to the router?
Keep in mind i'm an absolute bafoon when it comes to Linux, so any help is greatly appreciated!

Openwrt instructions page: https://openwrt.org/toh/xiaomi/ax3600

SSH access on a LAN port should work. Don’t connect to the WAN port. Assign the IP on your other box to a static address in the 192.168.1.x subset. Ssh command: ssh root@192.168.1.1

1 Like

If you flashed a stable OpenWrt version (i.e. 23.05.3), then you can just use your browser for the remaining steps:

  • connect to http://192.168.1.1 via your browser and log in
  • Do a firmware upgrade using a sysupgrade image

If it doesn't work, do some basic troubleshooting first:

  • Run ping 192.168.1.1 in a console - do you get replies?
  • Can you connect via SSH?

and so on.

2 Likes

Nope, used a lan port! How do i assign the ip on the router?
Thanks for replying!

It doesn't show up in wifi anymore, it might be because i'm not finished with the step i'm having issues with?

It's not going to show up in Wireless as the access point mode is disabled by default. You need to connect via LAN.

2 Likes

Wow, i cannot thank you enough dude.

So i can safely ignore step 9 and step 10?
Not sure why but i can't ssh to 192.168.1.1 it's saying my password is wrong?

By default, there is no password. Please post the exact error message.

Yes, if the sysupgrade via LuCI succeeds, then the warning that you are running from RAM is gone and it should work as intended.

1 Like

I didn't try just hitting enter when it prompts for a password.. that might be why!

I'll ping you again in a few days if the issue remains. (Currently moving and had to put the router away).
Thanks for all the prompt replies today my man, you're the best.

WTF is a gigachads?

2 Likes

To ssh to OpenWrt the first time, use username root i.e. ssh root@192.168.1.1 or ssh -l root 192.168.1.1. If you don't specify the username it will use your username from the machine you are sshing from, which will not work. Trying to log in as other than root will ask for a password but there is actually no password that will work for any user besides root. (The reason that ssh still asks for a password for non-existent users is to prevent probing the box to determine if a certain username exists or not).

Note that you should not ever run your ssh client as root, but specify "root" as the remote username to tell the remote box that you want to be root there.

A very handsome man, according to Google.
I think nerds is the proper term, at this forum.

3 Likes

OK thanks. :confused: hahahah I think I am old now!

1 Like

It's Gen Z slang meaning someone who's really cool/great/etc.

2 Likes